Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1291065 - Custom certificates not correctly deployed on capsule
Summary: Custom certificates not correctly deployed on capsule
Keywords:
Status: CLOSED DUPLICATE of bug 1218251
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Installer
Version: 6.1.3
Hardware: Unspecified
OS: Linux
medium
medium vote
Target Milestone: Unspecified
Assignee: Katello Bug Bin
QA Contact: Kedar Bidarkar
URL:
Whiteboard:
Depends On: 1330566
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-12-13 11:59 UTC by daniel
Modified: 2019-04-01 20:26 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-07-15 12:08:24 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:1500 normal SHIPPED_LIVE Red Hat Satellite 6.2 Base Libraries 2016-07-27 12:24:38 UTC
Red Hat Bugzilla 1120714 None None None Never

Internal Links: 1120714

Description daniel 2015-12-13 11:59:17 UTC
Description of problem:
When customer was following install guide to deploy custom certificates capsule was not working despite successful capsule-installer.
Customer found that
/etc/foreman-proxy/ssl_cert.pem
/etc/foreman-proxy/ssl_key.pem
have not been updated by the procedure and updated them manually, after that everything worked 

Version-Release number of selected component (if applicable): Satellite 6.1.3


How reproducible:


Steps to Reproduce:
1. Set up Satellite and external Capsule and check it's working 
2. Apply custom certificates on Satellite6 following install guide
3. Apply custom certificate on Capsule following install guide and 
   output of capsule-certs-generate 

Actual results:
not all certificates on capsule got updated but
/etc/foreman-proxy/ssl_cert.pem
/etc/foreman-proxy/ssl_key.pem
had to be updated by hand

Expected results:
capsule-installer shall not show successful installation 


Additional info:
according to the log files i could not find any hints why this failed

Comment 6 Kedar Bidarkar 2016-05-02 11:18:36 UTC
I think the issue could be here with updating the capsule with the new certs.

I believe for some reason the new certs from the newer version of the created pacakges inside the tar file, do not get installed. 

Will check in more detail and update here.


NOTE: Setting up everything the first time itself using the custom certs, works completely fine.

Comment 7 Ivan Necas 2016-07-15 12:08:24 UTC
I think this is a duplicate of another bug that is actually ON_QE

*** This bug has been marked as a duplicate of bug 1218251 ***


Note You need to log in before you can comment on or make changes to this bug.