Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 128893 - gnome-pilot applets - Invalid characters in key name
Summary: gnome-pilot applets - Invalid characters in key name
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-pilot
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Matthew Barnes
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: FC4Update
TreeView+ depends on / blocked
 
Reported: 2004-07-30 22:08 UTC by Michal Jaegermann
Modified: 2007-11-30 22:10 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-11-07 15:28:27 UTC


Attachments (Terms of Use)

Description Michal Jaegermann 2004-07-30 22:08:42 UTC
Description of problem:

An output of this command

desktop-menu-tool --print /etc/xdg/menus/applications.menu

ends with:

Warning: failed to load desktop file
"/usr/share/control-center-2.0/capplets/gpilotd-control-applet.desktop":
Error in section Desktop Entry at line 2: Invalid characters in key name
Warning: failed to load desktop file
"/usr/share/control-center-2.0/capplets/gpilotd-control-applet.desktop":
Error in section Desktop Entry at line 2: Invalid characters in key name

** ERROR **: file menu-process.c: line 1937 (foreach_print): assertion
failed: (error == NULL)
aborting...
Aborted

I assume that there are indeed "Invalid characters in key name".
OTOH it is a good question if a desktop-menu-tool should indeed
abort on such error instead of just skipping an invalid entry.

Version-Release number of selected component (if applicable):
gnome-pilot-2.0.10-9

How reproducible:
100%

Comment 1 Dave Malcolm 2004-11-02 19:13:17 UTC
The problem line says:
Encoding UTF-8

Looks like it should read:
Encoding=UTF-8


Comment 2 Dave Malcolm 2004-11-02 19:45:03 UTC
Indeed the spec is here:
http://www.freedesktop.org/standards/desktop-entry-spec

The lastest version in Rawhide (gnome-pilot-2.0.12-4) still has this
bug.  However the bug has already been fixed in upstream CVS, there
was a bug about it here:
http://bugzilla.gnome.org/show_bug.cgi?id=142170



Comment 5 John Thacker 2006-10-29 21:59:54 UTC
Changing version to correct one.  (test1 -> fc3test1, and some were filed as
test3 accidentally instead; but clearly must be fc3test1 given the date of filing.)

Comment 6 Matthew Barnes 2006-11-07 15:28:27 UTC
This seems to be fixed now in gnome-pilot-2.0.14-3.fc7.

The file in question has since moved to:
/usr/share/applications/gpilotd-control-applet.desktop


Note You need to log in before you can comment on or make changes to this bug.