Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1286672 - Insure that Windows Qemu Guest Agent VSS Provider is started after installation
Summary: Insure that Windows Qemu Guest Agent VSS Provider is started after installation
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Virtualization Tools
Classification: Community
Component: virtio-win
Version: unspecified
Hardware: Unspecified
OS: Windows
unspecified
low
Target Milestone: ---
Assignee: Yan Vugenfirer
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-11-30 13:22 UTC by seecubic
Modified: 2019-03-28 23:58 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-03-28 23:58:44 UTC


Attachments (Terms of Use)

Description seecubic 2015-11-30 13:22:07 UTC
Description of problem:

After installing the latest Qemu Guest Agent (7.2.1) from https://fedoraproject.org/wiki/Windows_Virtio_Drivers the QEMU Guest Agent VSS Provider service is being installed with startup type: Automatic.

After a backup the service is automatically being stopped causing monitoring systems like the Windows server manager to complain about stopped services with startup type automatic.

Because the Qemu guest agent starts the VSS provider service automatically when a backup is being triggered this can easily be solved by changing the startup type to: Manual.

I have now changed the startup type to manual using GPO for all my Qemu Windows guests but it would be better if the provided MSI installer registers the QEMU Guest Agent VSS Provider service with startup type manual during installation.

Version-Release number of selected component (if applicable):
7.2.1

How reproducible:
Always

Steps to Reproduce:
1. Install the latest Qemu guest agent from https://fedoraproject.org/wiki/Windows_Virtio_Drivers
2. Trigger a hyper-visor based backup and find the services being stopped after the backup has completed.
3. After step 2 monitoring systems like e.g. the Windows server manager start complaining that the Qemu guest agent VSS provider service is stopped while its startup type is automatic.

Actual results:
False monitoring alerts

Expected results:
Install Qemu guest agent VSS provider service with startup type manual during installation of the provides MSI package that will prevent false monitoring alerts.

Additional info:

Comment 1 Yan Vugenfirer 2017-03-16 14:00:54 UTC
The actual issue is that provider might not be stated by the installation process. Fixing it.

Comment 2 lijin 2017-08-17 07:37:57 UTC
xiagao,

Could you try to reproduce this issue and verify it?

Comment 3 seecubic 2017-08-17 08:31:46 UTC
FYI

Just verified Qemu Guest Agent 7.3.2 that is included into the virtio-win-0.1.126 iso (latest iso).  This one is still setting the QEMU Guest Agent VSS Provider service to startup type: Automatic.

Also verified the latest available Qemu Guest Agent 7.4.5 which now correctly sets the QEMU Guest Agent VSS Provider service to startup type: Manual.

Comment 4 xiagao 2017-08-17 09:56:45 UTC
> FYI
> 
> Just verified Qemu Guest Agent 7.3.2 that is included into the
> virtio-win-0.1.126 iso (latest iso).  This one is still setting the QEMU
> Guest Agent VSS Provider service to startup type: Automatic.
> 
> Also verified the latest available Qemu Guest Agent 7.4.5 which now
> correctly sets the QEMU Guest Agent VSS Provider service to startup type:
> Manual.

Hi,thanks for your testing. 


Verified this bug in qemu-ga-win-7.4.5.
Steps:
1.boot up a windows guest
2.install vioser driver and qemu-ga-x.msi,check VSS startup type is manual and status is null.
3.issue {"execute":"guest-fsfreeze-freeze"} in host and create snapshot, check VSS status is started
4.issue  {"execute":"guest-fsfreeze-thaw"}in host,check VSS status is null.

The result is expected from comment3 and comment 4.
So set it to VERIFIED.


Note You need to log in before you can comment on or make changes to this bug.