Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1283983 - nfs-ganesha: Upcall sent on null gfid
Summary: nfs-ganesha: Upcall sent on null gfid
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: ganesha-nfs
Version: mainline
Hardware: All
OS: All
unspecified
medium
Target Milestone: ---
Assignee: Soumya Koduri
QA Contact:
URL:
Whiteboard:
Depends On: 1283608
Blocks: 1278220 1287079
TreeView+ depends on / blocked
 
Reported: 2015-11-20 12:53 UTC by Soumya Koduri
Modified: 2016-06-16 13:45 UTC (History)
3 users (show)

Fixed In Version: glusterfs-3.8rc2
Doc Type: Bug Fix
Doc Text:
Clone Of: 1283608
: 1287079 (view as bug list)
Environment:
Last Closed: 2016-06-16 13:45:21 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Comment 1 Vijay Bellur 2015-11-20 12:56:16 UTC
REVIEW: http://review.gluster.org/12708 (defaults: Add 'GF_EVENT_UPCALL' to default_notify) posted (#1) for review on master by soumya k (skoduri@redhat.com)

Comment 2 Vijay Bellur 2015-11-23 05:33:17 UTC
REVIEW: http://review.gluster.org/12708 (defaults: Add 'GF_EVENT_UPCALL' to default_notify) posted (#2) for review on master by soumya k (skoduri@redhat.com)

Comment 3 Vijay Bellur 2015-11-27 06:42:15 UTC
REVIEW: http://review.gluster.org/12708 (defaults: Add 'GF_EVENT_UPCALL' to default_notify) posted (#3) for review on master by soumya k (skoduri@redhat.com)

Comment 4 Vijay Bellur 2015-11-27 06:42:17 UTC
REVIEW: http://review.gluster.org/12773 (Upcall: Read gfid from iatt in case of invalid inode) posted (#1) for review on master by soumya k (skoduri@redhat.com)

Comment 5 Vijay Bellur 2015-11-27 12:03:20 UTC
REVIEW: http://review.gluster.org/12773 (Upcall: Read gfid from iatt in case of invalid inode) posted (#2) for review on master by soumya k (skoduri@redhat.com)

Comment 6 Vijay Bellur 2015-11-30 13:00:19 UTC
REVIEW: http://review.gluster.org/12773 (Upcall: Read gfid from iatt in case of invalid inode) posted (#3) for review on master by soumya k (skoduri@redhat.com)

Comment 7 Vijay Bellur 2015-11-30 13:02:16 UTC
REVIEW: http://review.gluster.org/12773 (Upcall: Read gfid from iatt in case of invalid inode) posted (#4) for review on master by soumya k (skoduri@redhat.com)

Comment 8 Vijay Bellur 2015-12-01 10:32:54 UTC
COMMIT: http://review.gluster.org/12773 committed in master by Niels de Vos (ndevos@redhat.com) 
------
commit ffe80877a0eb0eaf2540be95b401623c6d7c722f
Author: Soumya Koduri <skoduri@redhat.com>
Date:   Fri Nov 27 12:09:22 2015 +0530

    Upcall: Read gfid from iatt in case of invalid inode
    
    When any file/dir is looked upon for the first time, inode
    created shall be invalid till it gets linked to the inode table.
    In such cases, read the gfid from the iatt structure returned
    as part of such fops for UPCALL processing.
    
    Change-Id: Ie5eb2f3be18c34cf7ef172e126c9db5ef7a8512b
    BUG: 1283983
    Signed-off-by: Soumya Koduri <skoduri@redhat.com>
    Reviewed-on: http://review.gluster.org/12773
    Reviewed-by: Kaleb KEITHLEY <kkeithle@redhat.com>
    Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Niels de Vos <ndevos@redhat.com>

Comment 9 Vijay Bellur 2015-12-01 10:35:06 UTC
COMMIT: http://review.gluster.org/12708 committed in master by Niels de Vos (ndevos@redhat.com) 
------
commit 3c18b186921c51b1a976eea8cd1c19f7113ef74c
Author: Soumya Koduri <skoduri@redhat.com>
Date:   Fri Nov 20 17:50:50 2015 +0530

    defaults: Add 'GF_EVENT_UPCALL' to default_notify
    
    Fix a regression caused by commit#If7d59d
    
    Change-Id: Ib2239b9b0e216302e6c89e21288592d35b8d124b
    BUG: 1283983
    Signed-off-by: Soumya Koduri <skoduri@redhat.com>
    Reviewed-on: http://review.gluster.org/12708
    Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    Reviewed-by: jiffin tony Thottan <jthottan@redhat.com>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Kaleb KEITHLEY <kkeithle@redhat.com>
    Reviewed-by: Niels de Vos <ndevos@redhat.com>

Comment 10 Niels de Vos 2016-06-16 13:45:21 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.0, please open a new bug report.

glusterfs-3.8.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://blog.gluster.org/2016/06/glusterfs-3-8-released/
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user


Note You need to log in before you can comment on or make changes to this bug.