Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1282148 - [abrt] solaar: window.py:795:update:AssertionError
Summary: [abrt] solaar: window.py:795:update:AssertionError
Keywords:
Status: CLOSED DUPLICATE of bug 1227465
Alias: None
Product: Fedora
Classification: Fedora
Component: solaar
Version: 23
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Eric Smith
QA Contact: Fedora Extras Quality Assurance
URL: https://retrace.fedoraproject.org/faf...
Whiteboard: abrt_hash:299c4a310e05b25171d8208def4...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-11-15 04:56 UTC by wintonian
Modified: 2015-11-15 05:07 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-11-15 05:07:13 UTC


Attachments (Terms of Use)
File: backtrace (deleted)
2015-11-15 04:56 UTC, wintonian
no flags Details
File: environ (deleted)
2015-11-15 04:57 UTC, wintonian
no flags Details

Description wintonian 2015-11-15 04:56:54 UTC
Description of problem:
I removed the unified reciver and plugged it back in.

Version-Release number of selected component:
solaar-0.9.2-4.20150528gitcf27328.fc23.1

Additional info:
reporter:       libreport-2.6.3
cmdline:        /usr/bin/python /usr/bin/solaar
executable:     /usr/bin/solaar
kernel:         4.2.6-300.fc23.x86_64
runlevel:       N 5
type:           Python
uid:            1000

Truncated backtrace:
window.py:795:update:AssertionError

Traceback (most recent call last):
  File "/usr/lib/python2.7/site-packages/solaar/ui/__init__.py", line 165, in _status_changed
    window.update(device, need_popup)
  File "/usr/lib/python2.7/site-packages/solaar/ui/window.py", line 795, in update
    assert device.receiver
AssertionError

Local variables in innermost frame:
device: <PairedDevice(1,4002,K750)>
is_paired: False
selected_device_id: ('/dev/hidraw0', 2)
need_popup: 0

Potential duplicate: bug 1227465

Comment 1 wintonian 2015-11-15 04:56:59 UTC
Created attachment 1094310 [details]
File: backtrace

Comment 2 wintonian 2015-11-15 04:57:00 UTC
Created attachment 1094311 [details]
File: environ

Comment 3 wintonian 2015-11-15 05:07:13 UTC

*** This bug has been marked as a duplicate of bug 1227465 ***


Note You need to log in before you can comment on or make changes to this bug.