Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 127626 - Philips USB speakers show up as 7 audio devices
Summary: Philips USB speakers show up as 7 audio devices
Keywords:
Status: CLOSED DUPLICATE of bug 79278
Alias: None
Product: Fedora
Classification: Fedora
Component: kudzu
Version: 2
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: David Lawrence
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-07-11 14:05 UTC by Bastien Nocera
Modified: 2014-03-17 02:46 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-02-21 19:04:24 UTC


Attachments (Terms of Use)

Description Bastien Nocera 2004-07-11 14:05:16 UTC
Description of problem:
When booting up with a Philips DSS350 Digital Speaker System plugged
in, kudzu asks for 7 different devices to be added

Version-Release number of selected component (if applicable):
kudzu-1.1.72-1

How reproducible:
Every time

Steps to Reproduce:
1. Plug in the Philips DSS350 Digital Speaker System
2. start kudzu by hand
3. get asked about a lot of new devices

Expected results:
Get asked only for one device

Additional info:
The part of /proc/bus/usb/devices regarding the device:

T:  Bus=01 Lev=01 Prnt=01 Port=00 Cnt=01 Dev#=  5 Spd=12  MxCh= 0
D:  Ver= 1.00 Cls=00(>ifc ) Sub=00 Prot=00 MxPS= 8 #Cfgs=  1
P:  Vendor=0471 ProdID=0101 Rev= 1.00
S:  Manufacturer=Philips Electronics
S:  Product=Philips USB Digital Speaker System
C:* #Ifs= 3 Cfg#= 1 Atr=40 MxPwr=  0mA
I:  If#= 0 Alt= 0 #EPs= 0 Cls=01(audio) Sub=01 Prot=00 Driver=audio
I:  If#= 1 Alt= 0 #EPs= 0 Cls=01(audio) Sub=02 Prot=00 Driver=audio
I:  If#= 1 Alt= 1 #EPs= 1 Cls=01(audio) Sub=02 Prot=00 Driver=audio
E:  Ad=04(O) Atr=09(Isoc) MxPS=  56 Ivl=1ms
I:  If#= 1 Alt= 2 #EPs= 1 Cls=01(audio) Sub=02 Prot=00 Driver=audio
E:  Ad=04(O) Atr=09(Isoc) MxPS= 112 Ivl=1ms
I:  If#= 1 Alt= 3 #EPs= 1 Cls=01(audio) Sub=02 Prot=00 Driver=audio
E:  Ad=04(O) Atr=09(Isoc) MxPS= 112 Ivl=1ms
I:  If#= 1 Alt= 4 #EPs= 1 Cls=01(audio) Sub=02 Prot=00 Driver=audio
E:  Ad=04(O) Atr=09(Isoc) MxPS= 224 Ivl=1ms
I:  If#= 1 Alt= 5 #EPs= 1 Cls=01(audio) Sub=02 Prot=00 Driver=audio
E:  Ad=04(O) Atr=09(Isoc) MxPS= 168 Ivl=1ms
I:  If#= 1 Alt= 6 #EPs= 1 Cls=01(audio) Sub=02 Prot=00 Driver=audio
E:  Ad=04(O) Atr=09(Isoc) MxPS= 336 Ivl=1ms
I:  If#= 2 Alt= 0 #EPs= 1 Cls=03(HID  ) Sub=00 Prot=00 Driver=usbhid
E:  Ad=83(I) Atr=03(Int.) MxPS=   1 Ivl=10ms

I have absolutely no idea what the additional devices are supposed to
be for...

Comment 1 Bill Nottingham 2004-07-12 21:17:19 UTC
Please see bug 72165 as well.



*** This bug has been marked as a duplicate of 79278 ***

Comment 2 Red Hat Bugzilla 2006-02-21 19:04:24 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.