Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1273077 - dnf install fails if local package is mentioned twice
Summary: dnf install fails if local package is mentioned twice
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: dnf
Version: 24
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Packaging Maintenance Team
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-10-19 14:10 UTC by Michael Mráka
Modified: 2016-05-13 12:17 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-04-04 12:38:42 UTC


Attachments (Terms of Use)

Description Michael Mráka 2015-10-19 14:10:39 UTC
Description of problem:

dnf install fails if local package is mentioned twice

Version-Release number of selected component (if applicable):
dnf-1.1.3-1.fc23.noarch

How reproducible:
always

Steps to Reproduce:
1. dnf download zsh-5.1.1-2.fc23.x86_64
2. dnf install zsh-5.1.1-2.fc23.x86_64.rpm zsh-5.1.1-2.fc23.x86_64.rpm
3.

Actual results:
Last metadata expiration check performed 0:47:50 ago on Mon Oct 19 16:48:44 2015.
Error: cannot install both zsh-5.1.1-2.fc23.x86_64 and zsh-5.1.1-2.fc23.x86_64
(try to add '--allowerasing' to command line to replace conflicting packages)
[root@fedora ~]# dnf install zsh-5.1.1-2.fc23.x86_64.rpm zsh-5.1.1-2.fc23.x86_64.rpm --allowerasing
Last metadata expiration check performed 0:55:21 ago on Mon Oct 19 16:48:44 2015.
Error: cannot install both zsh-5.1.1-2.fc23.x86_64 and zsh-5.1.1-2.fc23.x86_64


Expected results:
Last metadata expiration check performed 1:00:07 ago on Mon Oct 19 16:48:44 2015.
Dependencies resolved.
==========================================================================================================
 Package            Arch                  Version                       Repository                   Size
==========================================================================================================
Installing:
 zsh                x86_64                5.1.1-2.fc23                  @commandline                2.6 M

Transaction Summary
==========================================================================================================
Install  1 Package

Total size: 2.6 M
Installed size: 6.2 M
Is this ok [y/N]: 



Additional info:
It works for remote packages, i.e.
dnf install zsh zsh

Comment 1 Raphael Groner 2015-10-19 16:21:59 UTC
Propably this could break fedora-review, it tries to install any debuginfo package twice and fails.

Comment 2 Michal Luscon 2015-10-21 14:23:46 UTC
IIRC, it's because of our decision to treat local packages installation as a strict operation.

Could you please clarify how this could break fedora-review?

Comment 3 Raphael Groner 2015-10-22 16:19:01 UTC
DEBUG util.py:108:  touching file: /var/lib/mock/fedora-rawhide-x86_64/root/.ini
tialized
INFO backend.py:133:  installing package(s): /home/builder/fedora-review/1273927
-qtcurve/results/qtcurve-1.8.18-1.fc24.x86_64.rpm /home/builder/fedora-review/12
73927-qtcurve/results/qtcurve-libs-1.8.18-1.fc24.x86_64.rpm /home/builder/fedora
-review/1273927-qtcurve/results/qtcurve-gtk2-1.8.18-1.fc24.x86_64.rpm /home/buil
der/fedora-review/1273927-qtcurve/results/qtcurve-qt4-1.8.18-1.fc24.x86_64.rpm /
home/builder/fedora-review/1273927-qtcurve/results/qtcurve-debuginfo-1.8.18-1.fc
24.x86_64.rpm /home/builder/fedora-review/1273927-qtcurve/results/qtcurve-debugi
nfo-1.8.18-1.fc24.x86_64.rpm
DEBUG package_manager.py:92:  ['/usr/bin/dnf', '--installroot', '/var/lib/mock/f
edora-rawhide-x86_64/root/', '--releasever', '24', 'install', '/home/builder/fed
ora-review/1273927-qtcurve/results/qtcurve-1.8.18-1.fc24.x86_64.rpm', '/home/bui
lder/fedora-review/1273927-qtcurve/results/qtcurve-libs-1.8.18-1.fc24.x86_64.rpm
', '/home/builder/fedora-review/1273927-qtcurve/results/qtcurve-gtk2-1.8.18-1.fc
24.x86_64.rpm', '/home/builder/fedora-review/1273927-qtcurve/results/qtcurve-qt4
-1.8.18-1.fc24.x86_64.rpm', '/home/builder/fedora-review/1273927-qtcurve/results
/qtcurve-debuginfo-1.8.18-1.fc24.x86_64.rpm', '/home/builder/fedora-review/1273927-qtcurve/results/qtcurve-debuginfo-1.8.18-1.fc24.x86_64.rpm']
DEBUG util.py:535:  child environment: None
DEBUG util.py:468:  Executing command: ['/usr/bin/dnf', '--installroot', '/var/lib/mock/fedora-rawhide-x86_64/root/', '--releasever', '24', 'install', '/home/builder/fedora-review/1273927-qtcurve/results/qtcurve-1.8.18-1.fc24.x86_64.rpm', '/home/builder/fedora-review/1273927-qtcurve/results/qtcurve-libs-1.8.18-1.fc24.x86_64.rpm', '/home/builder/fedora-review/1273927-qtcurve/results/qtcurve-gtk2-1.8.18-1.fc24.x86_64.rpm', '/home/builder/fedora-review/1273927-qtcurve/results/qtcurve-qt4-1.8.18-1.fc24.x86_64.rpm', '/home/builder/fedora-review/1273927-qtcurve/results/qtcurve-debuginfo-1.8.18-1.fc24.x86_64.rpm', '/home/builder/fedora-review/1273927-qtcurve/results/qtcurve-debuginfo-1.8.18-1.fc24.x86_64.rpm', '--setopt=tsflags=nocontexts'] with env {'HOME': '/builddir', 'TERM': 'vt100', 'PROMPT_COMMAND': 'printf "\x1b]0;<mock-chroot>\x07<mock-chroot>"', 'LANG': 'de_DE.utf8', 'SHELL': '/bin/bash', 'CCACHE_UMASK': '002', 'LC_MESSAGES': 'C', 'CCACHE_DIR': '/tmp/ccache', 'PATH': '/usr/bin:/bin:/usr/sbin:/sbin', 'HOSTNAME': 'mock'} and shell False
DEBUG util.py:393:  Last metadata expiration check performed 0:00:00 ago on Thu Oct 22 16:27:21 2015.
DEBUG util.py:393:  Error: cannot install both qtcurve-debuginfo-1.8.18-1.fc24.x86_64 and qtcurve-debuginfo-1.8.18-1.fc24.x86_64
DEBUG util.py:393:  (try to add '--allowerasing' to command line to replace conflicting packages)
DEBUG util.py:515:  Child return code was: 1

Comment 4 Raphael Groner 2015-10-22 16:20:53 UTC
qtcurve as in comment #3 is just an example, I see this with all other package reviews analogously as well.

Comment 5 Raphael Groner 2016-02-11 12:06:23 UTC
friendly ping? What's the state about this bug?
Again: This nasty bug is noted in every log of f-r as a package installation error with debuginfo generated from c/c++ source.

Comment 6 Jan Kurik 2016-02-24 13:51:16 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 24 development cycle.
Changing version to '24'.

More information and reason for this action is here:
https://fedoraproject.org/wiki/Fedora_Program_Management/HouseKeeping/Fedora24#Rawhide_Rebase

Comment 7 Michal Luscon 2016-04-04 12:38:42 UTC
Hi,

Fedora Review should run dnf with --setopt=strict=false option if this is desired behavior.

I would consider this to be fixed by introduction of strict option --> closing.

Comment 8 Raphael Groner 2016-05-13 12:17:16 UTC
Not reproducible with fedora-review 0.6.1 (f03e4e7) last change: 2016-05-02, dnf .


Note You need to log in before you can comment on or make changes to this bug.