Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 127283 - dhclient not stopped when cardbus net card removed
Summary: dhclient not stopped when cardbus net card removed
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: hotplug
Version: 2
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact:
URL:
Whiteboard:
: 84453 150382 (view as bug list)
Depends On:
Blocks: FC4Target
TreeView+ depends on / blocked
 
Reported: 2004-07-05 22:51 UTC by Ian Collier
Modified: 2014-03-17 02:46 UTC (History)
5 users (show)

Fixed In Version: 2004_09_23-1
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-02-07 22:17:38 UTC


Attachments (Terms of Use)

Description Ian Collier 2004-07-05 22:51:53 UTC
Description of problem:
It confuses me that the hotplug system and not the pcmcia
system is responsible for the configuration of these cards
(for one thing, /var/lib/pcmcia/stab claims the sockets are
both empty even when I have a net connection, and for another
`cardctl suspend' doesn't seem to be supported.  But I digress).

The interface `eth1' is a 3Com OfficeConnect Cardbus card
configured using `neat' to obtain its address via DHCP.
It does this successfully, and `dhclient' thus runs in the
background.

If I eject this card, the message 

net.agent[24107]: remove event not handled

is logged and the dhclient is not killed.  So if I reinsert
it then there will be two dhclients running, both thinking
they control this interface.

The script /etc/hotplug/net.agent contains the claim:

            # right now it looks like only Gentoo wants to care about
            # unregistering network devices...

This would be a good place to insert something which executes
`ifdown' on Red Hat flavoured systems.  Unfortunately, ifdown
won't run if the HWADDR is specified in the interface configuration
because at this point the interface may already have been removed
from the system so the address can't be checked.  So maybe something
more explicit to kill the DHCP client may be in order.

(As it happens, `neat' apparently placed a completely bogus
HWADDR in my config file, so I removed it and `ifdown' now works.)

Version-Release number of selected component (if applicable):
hotplug-2004_04_01-1
kernel-2.6.6-1.435
pcmcia-cs-3.2.7-1.5

How reproducible:
Always

Steps to Reproduce:
1. Configure network Cardbus card to obtain address via DHCP
2. Insert card
3. Remove card
  
Actual results:
dhclient left running.

Expected results:
dhclient killed when network card removed.

Comment 1 Monty Walls 2005-01-24 17:18:16 UTC
Also present in fc3:  hotplug doesn't do anything on device removal
for network devices, so the interface is never downed. The problem
with not doing a proper down on the interface is that things like dhcp
or ipsec get left in limbo.

Comment 2 Bill Nottingham 2005-02-04 21:08:19 UTC
*** Bug 84453 has been marked as a duplicate of this bug. ***

Comment 3 Bill Nottingham 2005-02-07 22:17:38 UTC
A call to ifdown added in 2004_09_23-1. Note that this may very well
not do anything useful without modifying ifdown.

Comment 4 Bill Nottingham 2005-03-07 17:55:25 UTC
*** Bug 150382 has been marked as a duplicate of this bug. ***

Comment 5 Michal Jaegermann 2005-04-02 20:47:20 UTC
Just bumped into the same issue.  Calling ifdown in a remove is not good
enough although obviously at least that should be done.  If you have dhclient
process running on such interface, which is very likely, it lingers and
fills logs with messages in this style:

   .... dhclient: DHCPREQUEST on ath0 to 255.255.255.255 port 67
   .... dhclient: send_packet: No such device
   .... dhclient: DHCPDISCOVER on ath0 to 255.255.255.255 port 67 interval 6
   .... dhclient: send_packet: No such device

Doh!  We know that there is "no such device".  Hotplug was already informed.
about it.


Note You need to log in before you can comment on or make changes to this bug.