Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1271123 - [RFE] Support for reseller use-case of OSP
Summary: [RFE] Support for reseller use-case of OSP
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-keystone
Version: 6.0 (Juno)
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: ---
Assignee: John Dennis
QA Contact: nlevinki
URL: https://bugs.launchpad.net/keystone/+...
Whiteboard:
: 1271122 (view as bug list)
Depends On: 1062821
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-10-13 08:18 UTC by Pablo Iranzo Gómez
Modified: 2017-02-24 21:30 UTC (History)
12 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-02-24 21:25:54 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 2323021 None None None 2016-05-13 12:03:18 UTC

Description Pablo Iranzo Gómez 2015-10-13 08:18:00 UTC
Description of problem:

Customer would like to be able to resell *clouds* to their customers (reseller use case), so they can delegate full tenants to customers that could create/remove users only within that tenant, being unable to edit other tenants in the infrastructure or see any data from them


Actual results:

This is not possible as an admin user, will have admin access to all tenants


Expected results:

Confined admins within tenants so the reseller use case can be implemented

Additional info:

This apparently relies on Hierarchical Multi-Tenancy, which appeared on roadmaps for OSP7

Comment 7 Stephen Gordon 2015-10-14 20:55:40 UTC
*** Bug 1271122 has been marked as a duplicate of this bug. ***

Comment 12 Edu Alcaniz 2016-09-16 06:33:32 UTC
Hi, this BZ was assigned for RHOSP9, could you update the status please

Comment 15 Edu Alcaniz 2017-01-25 12:22:19 UTC
Could we update the status because it seems step up for OSP9.


Note You need to log in before you can comment on or make changes to this bug.