Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 127 - Wish: include suexec with distribution of apache
Summary: Wish: include suexec with distribution of apache
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: apache
Version: 5.2
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: David Lawrence
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1998-11-19 02:29 UTC by seva
Modified: 2008-05-01 15:37 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 1998-11-20 11:40:43 UTC


Attachments (Terms of Use)

Description seva 1998-11-19 02:29:18 UTC
Not a bug, just a suggestion to include suexec in the binary
RPMs.

suexec is a wrapper that lets you run CGI scripts as user
other then 'nobody' (or whatever the apache is running).

You probably don't want to enable it be default, but at
least include it in the RPMs please.

Docs can be found at http://localhost/manual/suexec.html
(of a apache machine)

Comment 1 seva 1998-11-19 03:48:59 UTC
BTW, Getting the source and compiling suexec ( 'make suexec' from
apache_1.3.3/src/support/) and then putting it to /usr/sbin/ works.

So all you have to do is include suexec bin to /usr/sbin.

Comment 2 seva 1998-11-19 14:01:59 UTC
Oh yeah, suexec has to be mode 4711 suid root

Comment 3 Preston Brown 1998-11-20 11:40:59 UTC
wishes aren't bugs.


Note You need to log in before you can comment on or make changes to this bug.