Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1269628 - [epel7s390x] galera SRPM does not build correctly on s390x
Summary: [epel7s390x] galera SRPM does not build correctly on s390x
Keywords:
Status: CLOSED DUPLICATE of bug 1092068
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: galera
Version: epel7
Hardware: s390x
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Ryan O'Hara
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: epel7s390x
TreeView+ depends on / blocked
 
Reported: 2015-10-07 19:15 UTC by IBM Bug Proxy
Modified: 2015-12-09 18:48 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-12-09 18:48:43 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
IBM Linux Technology Center 131473 None None None Never

Description IBM Bug Proxy 2015-10-07 19:15:24 UTC

Comment 1 IBM Bug Proxy 2015-10-07 19:15:26 UTC
The EPEL 7 SRPM for galera
https://dl.fedoraproject.org/pub/epel/7/SRPMS/g/galera-25.3.5-7.el7.src.rpm 
does not build correctly in Mock on s390x.

After adding architectural support for s390x in build_config.h, 2 tests fail and prevents Mock from building RPM.

The failed tests are:

Running suite(s): CRC32C implementation
0%: Checks: 2, Failures: 2, Errors: 0
galerautils/tests/gu_crc32c_test.c:56:F:test:test_software:0: Input '123456789' resulted in 0x10065321, expected 0xe3069283
galerautils/tests/gu_crc32c_test.c:56:F:test:test_hardware:0: Input '123456789' resulted in 0x10065321, expected 0xe3069283

Comment 2 IBM Bug Proxy 2015-10-31 00:52:05 UTC
------- Comment From bryan.chan@ca.ibm.com 2015-10-31 00:47 EDT-------
The CRC32C test bug has been fixed upstream since version 25.3.6. The s390x support has been shipped in 25.3.12.

Comment 3 Yaakov Selkowitz 2015-12-09 18:48:43 UTC

*** This bug has been marked as a duplicate of bug 1092068 ***


Note You need to log in before you can comment on or make changes to this bug.