Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1269461 - Feature: Entry self-heal performance enhancements using more granular changelogs
Summary: Feature: Entry self-heal performance enhancements using more granular changelogs
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: replicate
Version: mainline
Hardware: Unspecified
OS: Linux
high
medium
Target Milestone: ---
Assignee: bugs@gluster.org
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: Gluster-HC-2 1361098
TreeView+ depends on / blocked
 
Reported: 2015-10-07 12:03 UTC by Krutika Dhananjay
Modified: 2016-07-28 10:49 UTC (History)
7 users (show)

Fixed In Version: glusterfs-3.8rc2
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 1361098 (view as bug list)
Environment:
Last Closed: 2016-06-16 13:39:34 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Krutika Dhananjay 2015-10-07 12:03:48 UTC
Description of problem:

Opening a BZ to track the work wrt entry sh performance improvements.
More details can be found @ http://www.gluster.org/pipermail/gluster-devel/2015-September/046773.html

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Vijay Bellur 2015-10-28 12:07:22 UTC
REVIEW: http://review.gluster.org/12442 (cluster/afr: [WIP] Entry self-heal performance enhancements) posted (#1) for review on master by Krutika Dhananjay (kdhananj@redhat.com)

Comment 2 Vijay Bellur 2015-10-29 11:01:06 UTC
REVIEW: http://review.gluster.org/12442 (cluster/afr: [WIP] Entry self-heal performance enhancements) posted (#2) for review on master by Krutika Dhananjay (kdhananj@redhat.com)

Comment 3 Vijay Bellur 2015-11-02 03:27:12 UTC
REVIEW: http://review.gluster.org/12482 (afr/index: changes for granular entry self-heal) posted (#1) for review on master by Ravishankar N (ravishankar@redhat.com)

Comment 4 Vijay Bellur 2015-11-02 12:41:07 UTC
REVIEW: http://review.gluster.org/12442 (cluster/afr: [WIP] Entry self-heal performance enhancements) posted (#3) for review on master by Krutika Dhananjay (kdhananj@redhat.com)

Comment 5 Mike McCune 2016-03-28 22:22:31 UTC
This bug was accidentally moved from POST to MODIFIED via an error in automation, please see mmccune@redhat.com with any questions

Comment 6 Vijay Bellur 2016-04-19 04:46:37 UTC
REVIEW: http://review.gluster.org/12442 (cluster/afr: [WIP] Entry self-heal performance enhancements) posted (#5) for review on master by Krutika Dhananjay (kdhananj@redhat.com)

Comment 7 Vijay Bellur 2016-04-21 03:22:40 UTC
REVIEW: http://review.gluster.org/12442 (cluster/afr: [WIP] Entry self-heal performance enhancements) posted (#6) for review on master by Krutika Dhananjay (kdhananj@redhat.com)

Comment 8 Vijay Bellur 2016-04-26 04:52:13 UTC
REVIEW: http://review.gluster.org/12482 (afr/index: changes for granular entry self-heal) posted (#4) for review on master by Pranith Kumar Karampuri (pkarampu@redhat.com)

Comment 9 Vijay Bellur 2016-04-26 04:53:37 UTC
REVIEW: http://review.gluster.org/12482 (afr/index: changes for granular entry self-heal) posted (#5) for review on master by Pranith Kumar Karampuri (pkarampu@redhat.com)

Comment 10 Vijay Bellur 2016-04-26 05:26:41 UTC
REVIEW: http://review.gluster.org/12442 (cluster/afr: [WIP] Entry self-heal performance enhancements) posted (#7) for review on master by Krutika Dhananjay (kdhananj@redhat.com)

Comment 11 Vijay Bellur 2016-04-26 08:53:39 UTC
REVIEW: http://review.gluster.org/12442 (cluster/afr: [WIP] Entry self-heal performance enhancements) posted (#8) for review on master by Krutika Dhananjay (kdhananj@redhat.com)

Comment 12 Vijay Bellur 2016-04-26 13:04:44 UTC
REVIEW: http://review.gluster.org/12442 (cluster/afr: [WIP] Entry self-heal performance enhancements) posted (#9) for review on master by Krutika Dhananjay (kdhananj@redhat.com)

Comment 13 Vijay Bellur 2016-04-26 13:04:48 UTC
REVIEW: http://review.gluster.org/12482 (afr/index: changes for granular entry self-heal) posted (#6) for review on master by Krutika Dhananjay (kdhananj@redhat.com)

Comment 14 Vijay Bellur 2016-04-26 13:04:52 UTC
REVIEW: http://review.gluster.org/14078 (granular esh: protocol/client fix) posted (#1) for review on master by Krutika Dhananjay (kdhananj@redhat.com)

Comment 15 Vijay Bellur 2016-04-28 14:36:05 UTC
REVIEW: http://review.gluster.org/12442 (cluster/afr: Entry self-heal performance enhancements) posted (#10) for review on master by Krutika Dhananjay (kdhananj@redhat.com)

Comment 16 Vijay Bellur 2016-04-28 14:36:09 UTC
REVIEW: http://review.gluster.org/12482 (afr/index: changes for granular entry self-heal) posted (#7) for review on master by Krutika Dhananjay (kdhananj@redhat.com)

Comment 17 Vijay Bellur 2016-04-28 14:36:13 UTC
REVIEW: http://review.gluster.org/14078 (protocol/client: Use loc->pargfid if loc->parent(->gfid) is not filled) posted (#2) for review on master by Krutika Dhananjay (kdhananj@redhat.com)

Comment 18 Vijay Bellur 2016-04-28 15:50:48 UTC
REVIEW: http://review.gluster.org/14078 (protocol/client: Use loc->pargfid if loc->parent(->gfid) is not filled) posted (#3) for review on master by Krutika Dhananjay (kdhananj@redhat.com)

Comment 19 Vijay Bellur 2016-04-28 16:01:44 UTC
REVIEW: http://review.gluster.org/12442 (cluster/afr: Entry self-heal performance enhancements) posted (#11) for review on master by Krutika Dhananjay (kdhananj@redhat.com)

Comment 20 Vijay Bellur 2016-04-28 20:46:09 UTC
COMMIT: http://review.gluster.org/14078 committed in master by Jeff Darcy (jdarcy@redhat.com) 
------
commit 40e96c17647b281264783520f8fbdd9056332b4c
Author: Krutika Dhananjay <kdhananj@redhat.com>
Date:   Tue Apr 26 16:05:04 2016 +0530

    protocol/client: Use loc->pargfid if loc->parent(->gfid) is not filled
    
    Change-Id: Id73bf635ca94dcf7518b33e529ffca07daeeb1f4
    BUG: 1269461
    Signed-off-by: Krutika Dhananjay <kdhananj@redhat.com>
    Reviewed-on: http://review.gluster.org/14078
    Reviewed-by: Pranith Kumar Karampuri <pkarampu@redhat.com>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    Smoke: Gluster Build System <jenkins@build.gluster.com>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.com>

Comment 21 Vijay Bellur 2016-04-29 11:03:49 UTC
REVIEW: http://review.gluster.org/12442 (cluster/afr: Entry self-heal performance enhancements) posted (#12) for review on master by Krutika Dhananjay (kdhananj@redhat.com)

Comment 22 Vijay Bellur 2016-04-29 13:23:32 UTC
REVIEW: http://review.gluster.org/12442 (cluster/afr: Entry self-heal performance enhancements) posted (#13) for review on master by Krutika Dhananjay (kdhananj@redhat.com)

Comment 23 Vijay Bellur 2016-04-30 01:21:59 UTC
COMMIT: http://review.gluster.org/12442 committed in master by Pranith Kumar Karampuri (pkarampu@redhat.com) 
------
commit 84c8cc9c5936a2a7539f343c180f06312c8f6d39
Author: Krutika Dhananjay <kdhananj@redhat.com>
Date:   Wed Oct 14 14:14:51 2015 +0530

    cluster/afr: Entry self-heal performance enhancements
    
    Change-Id: I52da41dff5619492b656c2217f4716a6cdadebe0
    BUG: 1269461
    Signed-off-by: Krutika Dhananjay <kdhananj@redhat.com>
    Reviewed-on: http://review.gluster.org/12442
    Reviewed-by: Pranith Kumar Karampuri <pkarampu@redhat.com>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    Smoke: Gluster Build System <jenkins@build.gluster.com>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.com>

Comment 24 Vijay Bellur 2016-04-30 01:22:53 UTC
REVIEW: http://review.gluster.org/12482 (afr, index: changes for granular entry self-heal) posted (#8) for review on master by Krutika Dhananjay (kdhananj@redhat.com)

Comment 25 Vijay Bellur 2016-04-30 09:12:01 UTC
REVIEW: http://review.gluster.org/12482 (afr, index: changes for granular entry self-heal) posted (#9) for review on master by Pranith Kumar Karampuri (pkarampu@redhat.com)

Comment 26 Vijay Bellur 2016-04-30 10:47:48 UTC
REVIEW: http://review.gluster.org/12482 (afr/index: changes for granular entry self-heal) posted (#10) for review on master by Krutika Dhananjay (kdhananj@redhat.com)

Comment 27 Vijay Bellur 2016-04-30 10:47:52 UTC
REVIEW: http://review.gluster.org/14130 (tests: Add test cases for add/replace brick with granular entry sh) posted (#1) for review on master by Krutika Dhananjay (kdhananj@redhat.com)

Comment 28 Vijay Bellur 2016-04-30 13:44:10 UTC
COMMIT: http://review.gluster.org/12482 committed in master by Pranith Kumar Karampuri (pkarampu@redhat.com) 
------
commit 0eb8e055b739112ac8b70073ef6e4e3f57c43e08
Author: Ravishankar N <ravishankar@redhat.com>
Date:   Mon Nov 2 08:55:46 2015 +0530

    afr/index: changes for granular entry self-heal
    
    Implements new indices type ENTRY_CHANGES where other
    xlators can add/delete names.
    
    Change-Id: I01c5568997085e11d22ba36a4376c70b78fb3827
    BUG: 1269461
    Signed-off-by: Ravishankar N <ravishankar@redhat.com>
    Reviewed-on: http://review.gluster.org/12482
    Tested-by: Krutika Dhananjay <kdhananj@redhat.com>
    Tested-by: Pranith Kumar Karampuri <pkarampu@redhat.com>
    Smoke: Gluster Build System <jenkins@build.gluster.com>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Pranith Kumar Karampuri <pkarampu@redhat.com>

Comment 29 Vijay Bellur 2016-05-01 10:04:42 UTC
REVIEW: http://review.gluster.org/14130 (tests: Add test cases for add/replace brick with granular entry sh) posted (#2) for review on master by Krutika Dhananjay (kdhananj@redhat.com)

Comment 30 Vijay Bellur 2016-05-01 13:43:22 UTC
COMMIT: http://review.gluster.org/14130 committed in master by Niels de Vos (ndevos@redhat.com) 
------
commit 65dfbc4fd1c2ebd0189c52673b17b416d4c4d37a
Author: Krutika Dhananjay <kdhananj@redhat.com>
Date:   Fri Apr 29 13:42:54 2016 +0530

    tests: Add test cases for add/replace brick with granular entry sh
    
    Most of the tests borrowed from Anuradha's original replace-brick
    and add-brick tests under tests/basic/afr/.
    
    Change-Id: I874c04a6af3223e07aa6099b818ff502b6ba2a15
    BUG: 1269461
    Signed-off-by: Krutika Dhananjay <kdhananj@redhat.com>
    Reviewed-on: http://review.gluster.org/14130
    Smoke: Gluster Build System <jenkins@build.gluster.com>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    Reviewed-by: Pranith Kumar Karampuri <pkarampu@redhat.com>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.com>

Comment 31 Niels de Vos 2016-06-16 13:39:34 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.0, please open a new bug report.

glusterfs-3.8.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://blog.gluster.org/2016/06/glusterfs-3-8-released/
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user


Note You need to log in before you can comment on or make changes to this bug.