Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1269300 - Fedora 23 Install Issue on PPC64LE Server with Avago RAID card
Summary: Fedora 23 Install Issue on PPC64LE Server with Avago RAID card
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 23
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: F-ExcludeArch-ppc64le, PPC64LETracker
TreeView+ depends on / blocked
 
Reported: 2015-10-06 22:53 UTC by adi.gangidi
Modified: 2015-11-19 12:21 UTC (History)
8 users (show)

Fixed In Version: kernel-4.2.6-300.fc23 kernel-4.2.6-200.fc22
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-11-19 09:56:17 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Launchpad 1475166 None None None Never

Description adi.gangidi 2015-10-06 22:53:49 UTC
Description of problem:

Fedora 23 Alpha PPC64LE Install fails on server with Avago RAID based storage (root cause analyzed) which is caused by bug in driver for Avago RAID card. The fix from Avago in process and this bug was created to track the merge of these fixes to Upstream.  

This bug manifests itself to the end user who is installing Fedora 23/22 on Avago RAID based as: Partitioning / mounting of file system as “ext4” failed. Hence the install process fails.

Work around for this bug is pasted at the bottom of the bug text. 

More details about bug can be found in last few comments of this ubuntu bug (We found this bug while installing ubuntu 15.04  for the first time):
https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1475166



Version-Release number of selected component (if applicable):

Fedora 23 Alhpa Server Release
https://dl.fedoraproject.org/pub/fedora-secondary/releases/test/23_Alpha/Server/ppc64le/iso/


How reproducible:
100%


Steps to Reproduce:
1. Configure storage on Avago raid card
2. Install Avago RAID
3. You will run into errors pertaining the drive and install will fail


Actual results:

Install fails


Expected results:

Install should succeed 


Work around:
For now following work around can be used to install Fedora 23 on power systems with Avago raid card:

1) Power on and wait system boots into Petitboot:
    1a) Press "e" on "Install Fedora 23 (64-bit kernel)" option and append "megaraid_sas.max_sectors=2048" in the end of "boot argument"
2) Select modified option and follow the installation process. 
3) After install is complete and you are back to Petitboot: Edit booting option by appending megaraid_sas.max_sectors=2048, and boot with completed install.
***IMPORTANT NOTE***  Step 3 is needed for every boot time, or you will get system going to failure due to system can't mount file system. 
Alternatively we can add this to Grub config to avoid repeating this process.

Additional info:

Comment 1 Josh Boyer 2015-10-29 12:37:14 UTC
I've not seen the theoretical patches mentioned in the Launchpad bug get sent upstream.  It is possible that I missed them.  Does anyone have pointers to the suspected fixes?

Comment 2 adi.gangidi 2015-11-04 16:09:32 UTC
Here is the reply I got from Avago rep who submitted a patch upstream:



Adi –
 
We have already submitted patch to upstream. See attached upstream patch. We are currently waiting for commit by upstream.
 
 
` Kashyap (Avago India)

Comment 3 Josh Boyer 2015-11-04 16:12:30 UTC
(In reply to adi.gangidi from comment #2)
> Here is the reply I got from Avago rep who submitted a patch upstream:
> 
> 
> 
> Adi –
>  
> We have already submitted patch to upstream. See attached upstream patch. We
> are currently waiting for commit by upstream.
>  
>  
> ` Kashyap (Avago India)

Great.  Could you attach the patch they sent you?

Comment 4 adi.gangidi 2015-11-09 19:25:28 UTC
Hi Josh

Here is any update on patch on Ubuntu bug tracking system (Launchpad):


Hi Adi,

I see the patch got posted here - https://www.spinics.net/lists/linux-scsi/msg89336.html and it has been reviewed.

I'm guessing it will be part of a scsi pull request in the recently opened 4.4 merge window. That looks imminent. Depending on when it lands, the Ubuntu kernel update cycle takes about a month.

Kind regards,
Bryan


Link to Launch pad: https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1475166

Comment 5 Josh Boyer 2015-11-10 13:49:57 UTC
Thanks.  I'll bring this in today.  It's too late for F23 release, but it will be available as an update.

Comment 6 adi.gangidi 2015-11-10 19:31:47 UTC
Hey Josh

Sure. Pleas let me know when do that;.

I'd like to try the update on our Power system.

Thanks
Adi

Comment 7 Josh Boyer 2015-11-10 19:44:13 UTC
It will be in the 4.2.6 update and bodhi will leave a comment in this bug when it is available for testing.

Comment 8 Fedora Update System 2015-11-11 04:14:21 UTC
kernel-4.2.6-300.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2015-115c302856

Comment 9 Fedora Update System 2015-11-11 04:15:36 UTC
kernel-4.2.6-200.fc22 has been submitted as an update to Fedora 22. https://bodhi.fedoraproject.org/updates/FEDORA-2015-cd94ad8d7c

Comment 10 Fedora Update System 2015-11-12 02:24:35 UTC
kernel-4.2.6-200.fc22 has been pushed to the Fedora 22 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update kernel'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-cd94ad8d7c

Comment 11 Fedora Update System 2015-11-12 03:58:17 UTC
kernel-4.2.6-300.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update kernel'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-115c302856

Comment 12 Fedora Update System 2015-11-19 09:54:42 UTC
kernel-4.2.6-300.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.

Comment 13 Fedora Update System 2015-11-19 12:19:49 UTC
kernel-4.2.6-200.fc22 has been pushed to the Fedora 22 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.