Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 126528 - up2date +get source fails if no source available
Summary: up2date +get source fails if no source available
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: up2date
Version: 3.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Bryan Kearney
QA Contact: Beth Nackashi
URL:
Whiteboard:
: 143686 (view as bug list)
Depends On: 191773
Blocks: RHEL3U8CanFix
TreeView+ depends on / blocked
 
Reported: 2004-06-22 21:04 UTC by Todd Warner
Modified: 2013-01-10 08:47 UTC (History)
2 users (show)

Fixed In Version: RHBA-2006-0465
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-07-20 15:13:39 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2006:0465 normal SHIPPED_LIVE up2date bug fix update 2006-07-19 20:50:00 UTC

Description Todd Warner 2004-06-22 21:04:17 UTC
up2date --configure
Retrieval/Installation
Turn on: "Retreive source RPM along with binary package"

up2date -u
If no source package is available, the up2date process fails. This may
or may not be correct behavior. I suspect incorrect.

Proper behavior may be a warning?

Comment 1 Adrian Likins 2004-09-02 15:54:00 UTC
changing comp to rhel4 

Comment 4 Fanny Augustin 2006-04-11 00:34:51 UTC
Blocking rhnupr4u4 and rhnupr3u8 to track the progress of the release

Comment 5 Fanny Augustin 2006-04-13 19:40:32 UTC
Moving bugs to the CanFix List

Comment 6 James Bowes 2006-04-27 23:52:56 UTC
Now the user will be shown a warning message, but up2date will continue to run.

Comment 9 Frank Hirtz 2006-05-04 13:59:13 UTC
*** Bug 143686 has been marked as a duplicate of this bug. ***

Comment 10 Fanny Augustin 2006-05-09 20:34:48 UTC
Re-aligning to correct bug trackers

Comment 11 Beth Nackashi 2006-05-15 16:20:38 UTC
"Retrieval/Installation" corresponds to "retrieveSource" (Comment: Retrieve
source RPM along with binary package) in the --nox version of up2date.

Packages tested:
up2date-4.4.69-8
rhnlib-1.8.7-1

This does not fail cleanly as hoped:

[root@test07 root]# up2date --get acroread

Fetching all package list for channel: rhel-i386-as-3...
########################################

Fetching all package list for channel: rhel-i386-as-3-extras...
########################################

Fetching all package list for channel: rhn-tools-rhel-3-as-i386...
########################################

Fetching all package list for channel: rhel-i386-as-3-fastrack...
########################################

Fetching package list for channel: rhel-i386-as-3...
########################################

Fetching package list for channel: rhel-i386-as-3-extras...
########################################

Fetching package list for channel: rhn-tools-rhel-3-as-i386...
########################################

Fetching package list for channel: rhel-i386-as-3-fastrack...
########################################

acroread-7.0.1-1.1.0.EL3.i386.rpm...
########################################
An error has occurred:
exceptions.Exception
See /var/log/up2date for more information

[Mon May 15 12:15:19 2006] up2date   File "/usr/sbin/up2date", line 1282, in ?
    sys.exit(main() or 0)
   File "/usr/sbin/up2date", line 708, in main
    return getPackages(pkgNames)
   File "/usr/sbin/up2date", line 1062, in getPackages
    onlySource = source)
   File "/usr/share/rhn/up2date_client/up2date.py", line 188, in getPackage
    msgCallback, progressCallback)
   File "/usr/share/rhn/up2date_client/rpcServer.py", line 236, in doCall
    ret = apply(method, args, kwargs)
   File "/usr/share/rhn/up2date_client/repoDirector.py", line 40, in
getPackageSource
    return self.handlers[channel['type']].getPackageSource(channel, pkg,
msgCallback, progressCallback)
   File "/usr/share/rhn/up2date_client/rpmSource.py", line 201, in getPackageSource
    MsgCallback, progressCallback)
   File "/usr/share/rhn/up2date_client/repoBackends/up2dateRepo.py", line 242,
in getPackageSource
    fd = self.s.getPackageSource(channel['label'], filename)
   File "/usr/lib/python2.2/site-packages/rhn/rpclib.py", line 609, in __call__
    result = self._send(self._name, args)
   File "/usr/lib/python2.2/site-packages/rhn/rpclib.py", line 397, in _request
    raise Exception("Error requesting with the server:: error code:: %s" %
save_response)



Comment 12 Beth Nackashi 2006-06-01 15:11:59 UTC
latest up2date and rhnlib packages:

/dist/3.0E-U8/up2date/4.4.69-10
/dist/3.0E-U8/rhnlib/1.8.7-3



Comment 13 Beth Nackashi 2006-06-01 17:06:27 UTC
up2date --get now fails with a proper warning message if the source RPM is not
found:

"warning: source RPM for acroread was not found."

The actual RPM does get retrieved:

[root@bnackash-64 tmp]# ll /var/spool/up2date/acroread-7.0.1-1.1.0.EL3.i386.*
-rw-r--r--    1 root     root        28916 Jun  1 13:13
/var/spool/up2date/acroread-7.0.1-1.1.0.EL3.i386.hdr
-rw-r--r--    1 root     root     35777640 Jun  1 13:13
/var/spool/up2date/acroread-7.0.1-1.1.0.EL3.i386.rpm


Comment 16 Red Hat Bugzilla 2006-07-20 15:13:39 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2006-0465.html



Note You need to log in before you can comment on or make changes to this bug.