Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1264023 - Fix or disable seamonkey on ppc64le
Summary: Fix or disable seamonkey on ppc64le
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: seamonkey
Version: rawhide
Hardware: ppc64le
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Gecko Maintainer
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: F-ExcludeArch-ppc64le, PPC64LETracker
TreeView+ depends on / blocked
 
Reported: 2015-09-17 10:41 UTC by Rafael Fonseca
Modified: 2015-09-17 20:37 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-09-17 20:37:59 UTC


Attachments (Terms of Use)

Description Rafael Fonseca 2015-09-17 10:41:23 UTC
Description of problem: seamonkey is excluded from ppc64. I don't know if it is supposed to be built for ppc64le. In case it isn't, then ppc64le should be added to the ExcludeArch section of the spec file. Otherwise, the ppc64le support needs to be added for the configure macros, since it fails with the following error:

ldap/sdks/c-sdk> loading cache /builddir/build/BUILD/seamonkey-2.35/comm-release/objdir/config.cache
ldap/sdks/c-sdk> checking host system type... /builddir/build/BUILD/seamonkey-2.35/comm-release/ldap/sdks/c-sdk/config/autoconf/config.guess: unable to guess system type
ldap/sdks/c-sdk> 
ldap/sdks/c-sdk> This script, last modified 2005-10-13, has failed to recognize
ldap/sdks/c-sdk> the operating system you are using. It is advised that you
ldap/sdks/c-sdk> download the most up to date version of the config scripts from
ldap/sdks/c-sdk> 
ldap/sdks/c-sdk>   http://savannah.gnu.org/cgi-bin/viewcvs/*checkout*/config/config/config.guess
ldap/sdks/c-sdk> and
ldap/sdks/c-sdk>   http://savannah.gnu.org/cgi-bin/viewcvs/*checkout*/config/config/config.sub
ldap/sdks/c-sdk> 
ldap/sdks/c-sdk> If the version you run (/builddir/build/BUILD/seamonkey-2.35/comm-release/ldap/sdks/c-sdk/config/autoconf/config.guess) is already up to date, please
ldap/sdks/c-sdk> send the following data and any information you think might be
ldap/sdks/c-sdk> pertinent to <config-patches@gnu.org> in order to provide the needed
ldap/sdks/c-sdk> information to handle your system.
ldap/sdks/c-sdk> 
ldap/sdks/c-sdk> config.guess timestamp = 2005-10-13
ldap/sdks/c-sdk> 
ldap/sdks/c-sdk> uname -m = ppc64le
ldap/sdks/c-sdk> uname -r = 3.17.2-300.fc21.ppc64le
ldap/sdks/c-sdk> uname -s = Linux
ldap/sdks/c-sdk> uname -v = #1 SMP Sat Nov 1 10:47:09 UTC 2014
ldap/sdks/c-sdk> 
ldap/sdks/c-sdk> /usr/bin/uname -p = ppc64le
ldap/sdks/c-sdk> /bin/uname -X     = 
ldap/sdks/c-sdk> 
ldap/sdks/c-sdk> hostinfo               = 
ldap/sdks/c-sdk> /bin/universe          = 
ldap/sdks/c-sdk> /usr/bin/arch -k       = 
ldap/sdks/c-sdk> /bin/arch              = ppc64le
ldap/sdks/c-sdk> /usr/bin/oslevel       = 
ldap/sdks/c-sdk> /usr/convex/getsysinfo = 
ldap/sdks/c-sdk> 
ldap/sdks/c-sdk> UNAME_MACHINE = ppc64le
ldap/sdks/c-sdk> UNAME_RELEASE = 3.17.2-300.fc21.ppc64le
ldap/sdks/c-sdk> UNAME_SYSTEM  = Linux
ldap/sdks/c-sdk> UNAME_VERSION = #1 SMP Sat Nov 1 10:47:09 UTC 2014
ldap/sdks/c-sdk> configure: error: can not guess host type; you must specify one
*** Fix above errors and then restart with\
               "make -f client.mk build"


Version-Release number of selected component (if applicable): 2.35-1


How reproducible: ppc-koji build seamonkey on ppc64le guest.

Comment 1 Dmitry Butskoy 2015-09-17 20:37:59 UTC
ppc64le excluded as well


Note You need to log in before you can comment on or make changes to this bug.