Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1257186 - Use valgrind on wider amount of architectures
Summary: Use valgrind on wider amount of architectures
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: hyphen
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Caolan McNamara
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: ZedoraTracker ARM64, F-ExcludeArch-aarch64 F-ExcludeArch-ppc64le, PPC64LETracker
TreeView+ depends on / blocked
 
Reported: 2015-08-26 12:43 UTC by Marcin Juszkiewicz
Modified: 2016-01-20 10:38 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-01-20 10:38:59 UTC


Attachments (Terms of Use)
spec change (deleted)
2015-08-26 12:43 UTC, Marcin Juszkiewicz
no flags Details

Description Marcin Juszkiewicz 2015-08-26 12:43:49 UTC
Created attachment 1067239 [details]
spec change

Description of problem:

Hyphen installs Valgrind on x86(-64) but then uses it only on x86 because it failed on x86-64 in past. But nowadays we have Valgrind support on all architectures with exception of s390.

I tested on primary (x86, x86-64, arm), aarch64, ppc64(le), s390(x) and package built on all of them except arm (so I disabled test for it).

Version-Release number of selected component (if applicable):

2.8.8-2

How reproducible:

always

Steps to Reproduce:
1. enable valgrind
2. do builds on primary and secondary architectures

Actual results:

tests with valgrind are done on x86 only

Expected results:

tests with valgrind are done on as many architectures as possible

Additional info:

Comment 1 Marcin Juszkiewicz 2016-01-20 10:38:59 UTC
pushed to rawhide


Note You need to log in before you can comment on or make changes to this bug.