Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1254606 - efl: use new lua's api for getting global value on ppc
Summary: efl: use new lua's api for getting global value on ppc
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: efl
Version: rawhide
Hardware: ppc
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Tom "spot" Callaway
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: ZedoraTracker PPCTracker F-ExcludeArch-ppc64le, PPC64LETracker
TreeView+ depends on / blocked
 
Reported: 2015-08-18 13:37 UTC by Rafael Fonseca
Modified: 2015-10-07 22:50 UTC (History)
2 users (show)

Fixed In Version: efl-1.15.1-2.fc23 efl-1.15.1-2.fc22
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-10-01 16:04:45 UTC


Attachments (Terms of Use)
Fix compilation for lua > 5.1 on PPC (deleted)
2015-08-18 13:37 UTC, Rafael Fonseca
no flags Details | Diff

Description Rafael Fonseca 2015-08-18 13:37:55 UTC
Created attachment 1064324 [details]
Fix compilation for lua > 5.1 on PPC

Description of problem: because there is no luajit for PPC, EFL is compiled against lua-devel. When trying to build the latest EFL release on PPC, the following error is displayed:

lib/evas/filters/evas_filter_parser.c: In function '_lua_backtrace':
lib/evas/filters/evas_filter_parser.c:2434:20: error: 'LUA_GLOBALSINDEX' undeclared (first use in this function)
    lua_getfield(L, LUA_GLOBALSINDEX, "debug");

That happens because from lua > 5.1, the variable LUA_GLOBALSINDEX doesn't exist anymore.

Version-Release number of selected component (if applicable): 1.15.0-1


How reproducible: ppc-koji build EFL on PPC.


Additional info: patch provided.

Comment 1 Tom "spot" Callaway 2015-09-14 20:27:20 UTC
This is fixed in rawhide - efl-1.15.1-2.fc24 - (I didn't conditionalize it because it's clearly always correct with modern lua).

Comment 2 Fedora Update System 2015-09-21 09:31:13 UTC
efl-1.15.1-2.fc22 has been submitted as an update to Fedora 22. https://bodhi.fedoraproject.org/updates/FEDORA-2015-16307

Comment 3 Fedora Update System 2015-09-21 18:21:43 UTC
efl-1.15.1-2.fc22 has been pushed to the Fedora 22 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update efl'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-16307

Comment 4 Fedora Update System 2015-09-21 18:51:43 UTC
efl-1.15.1-2.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update efl'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-16308

Comment 5 Fedora Update System 2015-10-01 16:04:43 UTC
efl-1.15.1-2.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.

Comment 6 Fedora Update System 2015-10-07 22:50:29 UTC
efl-1.15.1-2.fc22 has been pushed to the Fedora 22 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.