Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1252975 - umockdev fails to build on ppc64 arches
Summary: umockdev fails to build on ppc64 arches
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Fedora
Classification: Fedora
Component: umockdev
Version: 24
Hardware: ppc64
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Bastien Nocera
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: PPCTracker F-ExcludeArch-ppc64le, PPC64LETracker
TreeView+ depends on / blocked
 
Reported: 2015-08-12 15:57 UTC by Rafael Fonseca
Modified: 2016-08-11 14:33 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-08-11 14:33:10 UTC


Attachments (Terms of Use)

Description Rafael Fonseca 2015-08-12 15:57:18 UTC
Description of problem: umockdev fails to build on ppc64/ppc64le with 

In file included from /usr/lib64/glib-2.0/include/glibconfig.h:9:0,
                 from /usr/include/glib-2.0/glib/gtypes.h:32,
                 from /usr/include/glib-2.0/glib/galloca.h:32,
                 from /usr/include/glib-2.0/glib.h:30,
                 from tests/test-ioctl-tree.c:21:
tests/test-ioctl-tree.c: In function 't_execute':
tests/test-ioctl-tree.c:436:45: error: invalid application of 'sizeof' to incomplete type 'struct termios'
     g_assert(ioctl_tree_execute(tree, last, TCGETS, NULL, &ret) == NULL);
                                             ^
/usr/include/glib-2.0/glib/gmacros.h:319:8: note: in definition of macro '_G_BOOLEAN_EXPR'
    if (expr)                                    \
        ^
/usr/include/glib-2.0/glib/gtestutils.h:106:49: note: in expansion of macro 'G_LIKELY'
                                              if G_LIKELY (expr) ; else \
                                                 ^
tests/test-ioctl-tree.c:436:5: note: in expansion of macro 'g_assert'
     g_assert(ioctl_tree_execute(tree, last, TCGETS, NULL, &ret) == NULL);
     ^
  CCLD     tests/chatter
Makefile:1292: recipe for target 'tests/tests_test_ioctl_tree-test-ioctl-tree.o' failed
make[2]: *** [tests/tests_test_ioctl_tree-test-ioctl-tree.o] Error 1

Version-Release number of selected component (if applicable): 0.8.8-3


How reproducible: koji-build umockdev on ppc64


Additional info: as -#include <termios.h> as been removed from /sysdeps/unix/sysv/linux/powerpc/bits/ioctl-types.h in glibc
since version glibc-2.19.90-32
see ttps://sourceware.org/git/?p=glibc.git;a=commit;h=d4795e4a43e6f0c221bc5dc64c612206a21a177b
in ioctls/vt.c
"#include <sys/ioctl.h>" is not enough.
"#include <sys/termios.h>" is now needed

This issue has been fixed in a newer upstream release [1]

[1] https://launchpad.net/umockdev/+milestone/0.8.10

Comment 1 Jan Kurik 2016-02-24 13:36:29 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 24 development cycle.
Changing version to '24'.

More information and reason for this action is here:
https://fedoraproject.org/wiki/Fedora_Program_Management/HouseKeeping/Fedora24#Rawhide_Rebase

Comment 2 Rafael Fonseca 2016-08-11 14:33:10 UTC
umockdev >= 0.8.11-1 builds successfully in koji. Closing this bug report.


Note You need to log in before you can comment on or make changes to this bug.