Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 125259 - dhclient run on bridge before interfaces are added
Summary: dhclient run on bridge before interfaces are added
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: initscripts
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: Brock Organ
URL:
Whiteboard:
Depends On:
Blocks: FC5Target
TreeView+ depends on / blocked
 
Reported: 2004-06-04 04:22 UTC by Andrew Jorgensen
Modified: 2014-03-17 02:45 UTC (History)
2 users (show)

Fixed In Version: 8.32-1
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-04-10 22:52:50 UTC


Attachments (Terms of Use)
fixes to ifdown, ifup, and network (deleted)
2004-08-03 21:00 UTC, Anders Kaseorg
no flags Details | Diff
Better patch, works with wireless (deleted)
2004-10-14 18:28 UTC, Anders Kaseorg
no flags Details | Diff

Description Andrew Jorgensen 2004-06-04 04:22:55 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6)
Gecko/20040518 Firefox/0.8

Description of problem:
I have configured a bridge as follows:

ifcfg-eth0:

DEVICE=eth0
ONBOOT=yes
TYPE=Ethernet
BRIDGE=br0

ifcfg-wlan0:

DEVICE=wlan0
ONBOOT=yes
TYPE=Wireless
BRIDGE=br0
ESSID=MyESSID
MODE=Managed
RATE=Auto

ifcfg-br0:

DEVICE=br0
ONBOOT=yes
TYPE=Bridge
BOOTPROTO=dhcp

On running 'service network restart' the bridge is brought up and an
attempt is made to get an address for it. Running 'brctl show' reveals
that the bridge is configured, but has no interfaces yet. This is
obviously not the correct behavior.

Version-Release number of selected component (if applicable):
initscripts-7.42.2-1

How reproducible:
Always

Steps to Reproduce:
1. Configure a bridge using the BRIDGE= and TYPE=Bridge directives in
ifcfg-*
2. Set the bridge device to get it's address by DHCP w/ BOOTPROTO=dhcp
3. Restart network.
    

Actual Results:  Scripts are unable to get an address for the bridge
because the bridge has no interfaces when dhclient is run.

Expected Results:  Bridge should be set up (with all appropriate
interfaces) before running dhclient.

Additional info:

I realize this breaks the paradigm of each device being configured
independant of other devices, but

Comment 1 Anders Kaseorg 2004-08-03 21:00:44 UTC
Created attachment 102408 [details]
fixes to ifdown, ifup, and network

Here's a patch to /sbin/ifdown, /sbin/ifup, and /etc/init.d/network that fixes
this problem for me. Bridge devices are now brought up after normal devices and
shut down before them. To make this work, a bridge is addbr'd right before the
first addif (if it doesn't exist) and delbr'd right after the last delif (if
there are no more ports).

Comment 2 Anders Kaseorg 2004-10-14 18:28:44 UTC
Created attachment 105220 [details]
Better patch, works with wireless

This fixes another bug: bridged wireless devices weren't getting initialized
properly.

Comment 3 Miloslav Trmač 2006-04-10 22:52:50 UTC
Fixed in initscripts-8.32-1.  Thanks for the patch!


Note You need to log in before you can comment on or make changes to this bug.