Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1249 - Problem parsing count parameters (always parses as 0)
Summary: Problem parsing count parameters (always parses as 0)
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: mt-st
Version: 5.2
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Michael K. Johnson
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-02-19 19:56 UTC by hornbeck
Modified: 2008-05-01 15:37 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 1999-04-10 03:50:11 UTC


Attachments (Terms of Use)

Description hornbeck 1999-02-19 19:56:17 UTC
There is a problem with mt-st-0.5.  For the 'mt' commands
processed by the 'do_standard' function, the count arguments
are not processed properly and are always treated as 0.

The problem is in 'mt.c' line 285 while reads :
  i = comp->cmd_function(mtfd, comp, argc - 2, &(argv[2]));

It should read :
    i = comp->cmd_function(mtfd, comp, argc - argn,
&(argv[argn]));

Comment 1 Michael K. Johnson 1999-04-10 03:50:59 UTC
Fixed in mt-st-0.5b AFAICT


Note You need to log in before you can comment on or make changes to this bug.