Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 124045 - Support setting a metric on interface routes
Summary: Support setting a metric on interface routes
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: initscripts
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: Brock Organ
URL:
Whiteboard:
: 131056 (view as bug list)
Depends On:
Blocks: FC5Target
TreeView+ depends on / blocked
 
Reported: 2004-05-23 05:37 UTC by Nickolai Zeldovich
Modified: 2014-03-17 02:45 UTC (History)
3 users (show)

Fixed In Version: 8.34-1
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-05-23 19:21:40 UTC


Attachments (Terms of Use)
Patch for /sbin/ifup (deleted)
2004-05-23 05:37 UTC, Nickolai Zeldovich
no flags Details | Diff

Description Nickolai Zeldovich 2004-05-23 05:37:15 UTC
The attached patches allow the user to specify a metric for the routes
of a given interface.  For instance, if they have two interfaces and
prefer one over another, whenever both are up, they can set the metric
values of the two interfaces appropriately and use the preferred one
when both are available.

This particular patch is for /sbin/ifup only -- i.e. just for
statically configured interfaces.  I'll clean up my patch for
/sbin/dhclient-script shortly -- in the meantime, do you think it'd be
best for me to open a second bug report for the dhclient-script
change?  They're really the same change, but for some reason Redhat
decided to split the logic across two packages.

-- kolya

Comment 1 Nickolai Zeldovich 2004-05-23 05:37:43 UTC
Created attachment 100470 [details]
Patch for /sbin/ifup

Comment 2 Bill Nottingham 2005-09-30 21:35:39 UTC
*** Bug 131056 has been marked as a duplicate of this bug. ***

Comment 3 Bill Nottingham 2006-05-23 19:21:40 UTC
A fix for this is in 8.34-1.


Note You need to log in before you can comment on or make changes to this bug.