Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 123827 - iwconfig segmentation fault when specifying WEP encryption key
Summary: iwconfig segmentation fault when specifying WEP encryption key
Keywords:
Status: CLOSED DUPLICATE of bug 78616
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 2
Hardware: i386
OS: Linux
medium
high
Target Milestone: ---
Assignee: Arjan van de Ven
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-05-20 20:17 UTC by Andrew Marshall
Modified: 2007-11-30 22:10 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-02-21 19:03:23 UTC


Attachments (Terms of Use)

Description Andrew Marshall 2004-05-20 20:17:52 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; VNIE5 
RefIE5)

Description of problem:
When specifying a 128bit encryption key with iwconfig

eg
iwconfig wlan0 key restricted <26 digit hex key>

a segmentation fault results, the system becomes unresponsive and 
hangs during the shutdown process.

A similar fault results from attempting to activate the connection 
with the network configuration GUI

ie.
/sbin/if : line 60 : 2709 Segmentation fault
iwconfig $DEVICE key $KEY

Version-Release number of selected component (if applicable):
26-4

How reproducible:
Always

Steps to Reproduce:
1.setup a wireless device
2.configure the device,
iwconfig <device> key restricted <key>

    

Additional info:

Comment 1 Alan Cox 2004-05-21 23:07:21 UTC
Which wireless card
Please also attach "dmesg" output after the segmentation fault.


Comment 2 Andrew Marshall 2004-05-22 15:12:13 UTC
The wireless card is an Intel Truemobile 1300, as installed on a Dell
Inspiron 8600.

lspci -v reports the following information

02:03.0 Network controller: Broadcom Corporation BCM94306 802.11g (rev 02)
        Subsystem: Dell Computer Corporation TrueMobile 1300 WLAN
Mini-PCI Card
        Flags: bus master, fast devsel, latency 32, IRQ 7
        Memory at faff6000 (32-bit, non-prefetchable)
        Capabilities: [40] Power Management version 2

The driver is ndiswrapper-0.7

Unfortunately I cannot attach dmesg information as the system becomes
unresponsive after seg faulting.

Andrew.

Comment 3 Arjan van de Ven 2004-05-22 15:38:20 UTC

*** This bug has been marked as a duplicate of 78616 ***

Comment 4 Red Hat Bugzilla 2006-02-21 19:03:23 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.