Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 123129 - oops with iwconfig
Summary: oops with iwconfig
Keywords:
Status: CLOSED DUPLICATE of bug 78616
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: rawhide
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Arjan van de Ven
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-05-12 19:43 UTC by jonathan baron
Modified: 2007-11-30 22:10 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-02-21 19:03:12 UTC


Attachments (Terms of Use)

Description jonathan baron 2004-05-12 19:43:28 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8a)
Gecko/20040504

Description of problem:
When I say
iwconfig wlan0 key 1234567890
I get a kernel oops.  I think this may
happen with other iwconfig commands.  I'm attaching two
segments of /var/log/messages.
After this oops, I have to remove the battery to restart
the computer.

(Hmm.  I can't find where to put attachments, so I'm pasting
them in the additional information box.)


Version-Release number of selected component (if applicable):
kernel-2.6.5-1.358smp

How reproducible:
Always

Steps to Reproduce:
1. It is difficult to answer this.  I'm trying to configure
a Broadcom BCM94306 wireless card with ndiswrapper.
2. I've installed ndiswrapper and everything checks out
3. except that link isn't found
    

Additional info:

May 12 09:33:21 delli modprobe: FATAL: Error inserting 3c501
(/lib/modules/2.6.5-1.358smp/kernel/drivers/net/3c501.ko): No such device 
May 12 09:33:21 delli modprobe: FATAL: Error inserting 3c501
(/lib/modules/2.6.5-1.358smp/kernel/drivers/net/3c501.ko): No such device 
May 12 09:33:41 delli kernel: ip_tables: (C) 2000-2002 Netfilter core team
May 12 09:36:49 delli gconfd (root-3117): GConf server is not in use,
shutting down.
May 12 09:36:49 delli gconfd (root-3117): Exiting
May 12 09:42:39 delli su(pam_unix)[3399]: session opened for user root
by baron(uid=500)
May 12 09:42:46 delli kernel: ip_tables: (C) 2000-2002 Netfilter core team
May 12 09:46:39 delli kernel: Unable to handle kernel paging request
at virtual address fef0e6e0
May 12 09:46:39 delli kernel:  printing eip:
May 12 09:46:39 delli kernel: 428be363
May 12 09:46:39 delli kernel: *pde = 00000000
May 12 09:46:39 delli kernel: Oops: 0000 [#1]
May 12 09:46:39 delli kernel: SMP 
May 12 09:46:39 delli kernel: CPU:    1
May 12 09:46:39 delli kernel: EIP:    0060:[<428be363>]    Tainted: P  
May 12 09:46:39 delli kernel: EFLAGS: 00210202   (2.6.5-1.358smp) 
May 12 09:46:39 delli kernel: EIP is at ndis_set_wep+0xa2/0x157
[ndiswrapper]
May 12 09:46:39 delli kernel: eax: 00000005   ebx: 39178220   ecx:
00000001   edx: 00000005
May 12 09:46:39 delli kernel: esi: fef0e6e0   edi: 2ad9ced0   ebp:
39178000   esp: 2ad9ceac
May 12 09:46:39 delli kernel: ds: 007b   es: 007b   ss: 0068
May 12 09:46:39 delli kernel: Process iwconfig (pid: 3637,
threadinfo=2ad9c000 task=2baaf930)
May 12 09:46:39 delli kernel: Stack: 29915067 035322a0 02140c53
00000005 00000005 000006e0 0000002c 80000000 
May 12 09:46:39 delli kernel:        00000005 035322a0 41756080
00000000 384f5ea1 fef0e6e5 00000005 fef0e6e0 
May 12 09:46:39 delli kernel:        384f5e9c 00008b2a 022ad5f8
00000001 2ad9cf44 00008b2a 02258de4 384f5e9c 
May 12 09:46:39 delli kernel: Call Trace:
May 12 09:46:39 delli kernel:  [<02140c53>] follow_page+0x128/0x134
May 12 09:46:39 delli kernel:  [<02258de4>]
wireless_process_ioctl+0x2bf/0x59a
May 12 09:46:39 delli kernel:  [<428be2c1>] ndis_set_wep+0x0/0x157
[ndiswrapper]
May 12 09:46:39 delli kernel:  [<022516b9>] dev_ioctl+0x266/0x29b
May 12 09:46:39 delli kernel:  [<02249cbd>] sock_ioctl+0x5e/0x2a7
May 12 09:46:39 delli kernel:  [<021441a4>] do_brk+0x1aa/0x1d5
May 12 09:46:39 delli kernel:  [<0215d98a>] sys_ioctl+0x207/0x243
May 12 09:46:39 delli kernel: 
May 12 09:46:39 delli kernel: Code: f3 a5 a8 02 74 02 66 a5 a8 01 74
01 a4 8d 44 24 04 ba 13 01 

May 12 10:14:51 delli kernel: Unable to handle kernel paging request
at virtual address fef18e10
May 12 10:14:51 delli kernel:  printing eip:
May 12 10:14:51 delli kernel: 428be363
May 12 10:14:51 delli kernel: *pde = 00000000
May 12 10:14:51 delli kernel: Oops: 0000 [#1]
May 12 10:14:51 delli kernel: SMP 
May 12 10:14:51 delli kernel: CPU:    0
May 12 10:14:51 delli kernel: EIP:    0060:[<428be363>]    Tainted: P  
May 12 10:14:51 delli kernel: EFLAGS: 00210202   (2.6.5-1.358smp) 
May 12 10:14:51 delli kernel: EIP is at ndis_set_wep+0xa2/0x157
[ndiswrapper]
May 12 10:14:51 delli kernel: eax: 00000005   ebx: 3ff2a220   ecx:
00000001   edx: 00000005
May 12 10:14:51 delli kernel: esi: fef18e10   edi: 2dc5bed0   ebp:
3ff2a000   esp: 2dc5beac
May 12 10:14:51 delli kernel: ds: 007b   es: 007b   ss: 0068
May 12 10:14:51 delli kernel: Process iwconfig (pid: 2922,
threadinfo=2dc5b000 task=300c21b0)
May 12 10:14:51 delli kernel: Stack: 2c2a8067 03585500 02140c53
00000005 00000005 00000e10 0000002c 80000000 
May 12 10:14:51 delli kernel:        00000005 03585500 39e11080
00000000 395fc8c1 fef18e15 00000005 fef18e10 
May 12 10:14:51 delli kernel:        395fc8bc 00008b2a 022ad5f8
00000001 2dc5bf44 00008b2a 02258de4 395fc8bc 
May 12 10:14:51 delli kernel: Call Trace:
May 12 10:14:51 delli kernel:  [<02140c53>] follow_page+0x128/0x134
May 12 10:14:51 delli kernel:  [<02258de4>]
wireless_process_ioctl+0x2bf/0x59a
May 12 10:14:51 delli kernel:  [<428be2c1>] ndis_set_wep+0x0/0x157
[ndiswrapper]
May 12 10:14:51 delli kernel:  [<022516b9>] dev_ioctl+0x266/0x29b
May 12 10:14:51 delli kernel:  [<02249cbd>] sock_ioctl+0x5e/0x2a7
May 12 10:14:51 delli kernel:  [<021441a4>] do_brk+0x1aa/0x1d5
May 12 10:14:51 delli kernel:  [<0215d98a>] sys_ioctl+0x207/0x243
May 12 10:14:51 delli kernel: 
May 12 10:14:51 delli kernel: Code: f3 a5 a8 02 74 02 66 a5 a8 01 74
01 a4 8d 44 24 04 ba 13 01

Comment 1 Arjan van de Ven 2004-05-12 19:46:20 UTC
unfortionately we cannot do anything with or about bugs with binary
only modules...

*** This bug has been marked as a duplicate of 78616 ***

Comment 2 Red Hat Bugzilla 2006-02-21 19:03:12 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.