Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1225 - Kernel-2.2 patches need psacct package recompiled, too
Summary: Kernel-2.2 patches need psacct package recompiled, too
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: psacct
Version: 5.2
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Mike A. Harris
QA Contact:
URL:
Whiteboard:
: 1509 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-02-18 06:02 UTC by Bob Plankers
Modified: 2008-05-01 15:37 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 1999-03-18 22:51:57 UTC


Attachments (Terms of Use)

Description Bob Plankers 1999-02-18 06:02:47 UTC
The kernel-2.2 directory on updates.redhat.com does not
include an updated psacct package, which breaks when RH 5.2
is upgraded to 2.2.x. A recompile, subsituting the acct.h
that is included with the 2.2.x kernels, seems to work for
me. Otherwise, the commands return garbage and often dump
core.

Comment 1 Jeff Johnson 1999-03-14 19:35:59 UTC
*** Bug 1509 has been marked as a duplicate of this bug. ***

psacct needs to be updated for 2.2 kernels.  However,
the caveat is that the autoconf script for it is broken.
After doing a ./configure, the config.h looks like:

/* Define if you have the <linux/acct.h> header file. */
/* #undef HAVE_LINUX_ACCT_H */

instead of the necessary

/* Define if you have the <linux/acct.h> header file. */
#define HAVE_LINUX_ACCT_H

so, in addition to recompiling against 2.2 headers, you'll
also either need to patch the autoconf stuff or else add
a kludge to sed the config.h after it's generated.

Ask away if you have more questions.  BTW, I'm assuming
this is true for all architectures; I've only noticed it
on i386, but because of why it broke, it should be true
on everything.

later,
chris

Comment 2 Bill Nottingham 1999-03-18 22:51:59 UTC
fixed in psacct-6.3-7


Note You need to log in before you can comment on or make changes to this bug.