Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1220494 - Broken dependencies
Summary: Broken dependencies
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: nodejs-handlebars
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Piotr Popieluch
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On: 965244 1108074
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-05-11 16:35 UTC by Ralph Bean
Modified: 2015-06-13 19:47 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-06-13 19:46:37 UTC


Attachments (Terms of Use)

Description Ralph Bean 2015-05-11 16:35:03 UTC
A package of mine that requires handlebars for its test suite is failing to build because handlebars cannot be installed:


  Error: Package: nodejs-handlebars-3.0.1-1.fc23.noarch (build)
             Requires: npm(optimist) >= 0.6.1
             Installing: nodejs-optimist-0.4.0-3.fc21.noarch (build)
                 npm(optimist) = 0.4.0
  Error: Package: nodejs-handlebars-3.0.1-1.fc23.noarch (build)
             Requires: npm(source-map) >= 0.1.40
             Installing: nodejs-source-map-0.1.33-2.fc21.noarch (build)
                 npm(source-map) = 0.1.33

Comment 1 Piotr Popieluch 2015-05-22 19:03:56 UTC
I would like to remove the latest build from rawhide as it is broken quite some time and I have no idea when (or if ever) the depending packages will be updated.

Ralph, do you know if we can delete the latest build from rawhide? From what I read this can only be done on the day of the build:
https://fedoraproject.org/wiki/Package_maintenance_guide#Removing_a_package_build_pending_for_Rawhide_or_Branched

Comment 2 Ralph Bean 2015-05-22 20:15:14 UTC
No, I don't think it's possible.

We could do an epoch build of an older version as a workaround, but that causes other problems down the road.

Comment 3 Zuzana Svetlikova 2015-05-23 19:08:17 UTC
Maybe a stupid question, but can't this be fixed by fixdep macros?

Comment 4 Piotr Popieluch 2015-05-24 17:55:52 UTC
Tried fixdep and it seems to work. Thank for suggestion. I thought to remember some backwards incompatible changes in newer source-map..

Package is built in rawhide, please check if it works for you.

Comment 5 Piotr Popieluch 2015-06-13 19:46:37 UTC
seems to work, closing

Comment 6 Piotr Popieluch 2015-06-13 19:47:11 UTC
seems to work, closing


Note You need to log in before you can comment on or make changes to this bug.