Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 121944 - Authentication fails when LDAP server is not available
Summary: Authentication fails when LDAP server is not available
Keywords:
Status: CLOSED DUPLICATE of bug 55193
Alias: None
Product: Fedora
Classification: Fedora
Component: authconfig
Version: 1
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Tomas Mraz
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-04-29 09:18 UTC by Paulo Silva
Modified: 2007-11-30 22:10 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2004-10-15 07:34:27 UTC


Attachments (Terms of Use)

Description Paulo Silva 2004-04-29 09:18:58 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6)
Gecko/20040413 Galeon/1.3.14 (Debian package 1.3.14a-1)

Description of problem:
I'm using the authconfig tool to configure the system's authentication
through an OpenLDAP local server. I was wondering what happened when the
server is down and I noticed that all authentication fails, even those
in the passwd file. I think it should fall back to normal account if
available.

Version-Release number of selected component (if applicable):
4.3.8-1

How reproducible:
Always

Steps to Reproduce:
1. Use authconfig to enable LDAP authentication.
2. Stop the LDAP server.
3. Try to login with an normal account.
    

Actual Results:  Login fails.

Expected Results:  Login with normal accounts (from /etc/passwd)
should be enabled.

Additional info:

By altering the pam_unix account line in the
/etc/pam.d/system-auth file from:

   account required /lib/security/$ISA/pam_unix.so

to

  account sufficient /lib/security/$ISA/pam_unix.so

I was able to get it right.

Comment 1 Jindrich Novy 2004-09-14 12:23:26 UTC
*** Bug 121451 has been marked as a duplicate of this bug. ***

Comment 2 Tomas Mraz 2004-10-15 07:31:46 UTC

*** This bug has been marked as a duplicate of 55193 ***


Note You need to log in before you can comment on or make changes to this bug.