Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 121061 - "apm -s" is the default suspend command even with ACPI
Summary: "apm -s" is the default suspend command even with ACPI
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-applets
Version: rawhide
Hardware: i586
OS: Linux
medium
medium
Target Milestone: ---
Assignee: David Zeuthen
QA Contact: Mike McLean
URL:
Whiteboard:
: 130685 140667 (view as bug list)
Depends On: 155613
Blocks: FC5Target
TreeView+ depends on / blocked
 
Reported: 2004-04-16 16:21 UTC by Kees
Modified: 2013-03-06 03:40 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-03-07 22:26:06 UTC


Attachments (Terms of Use)

Description Kees 2004-04-16 16:21:13 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040312

Description of problem:
The default suspend command of the applet is: /usr/bin/apm -s
Doesn't work because:

[kvdb@t-7-182 kvdb]$ apm --version
apm version 3.0.2
[kvdb@t-7-182 kvdb]$ apm
No APM support in kernel

Since the default kernels don't have APM enabled, the applet should
have another default (some ACPI sleep command?). Not?

Also weird:

/usr/libexec/battstat-applet-2 --version
Gnome battstat 0


Version-Release number of selected component (if applicable):
gnome-applets-2.6.0-2

How reproducible:
Always

Steps to Reproduce:
1. read above
2.
3.
    

Additional info:

Comment 1 Mark McLoughlin 2004-07-19 14:23:57 UTC

*** This bug has been marked as a duplicate of 121376 ***

Comment 2 Mark McLoughlin 2004-07-19 14:24:52 UTC
Wrong bug, sorry.

Comment 3 Mark McLoughlin 2004-07-19 14:27:09 UTC
Sounds reasonable. Just need to figure out what the ACPI command is.

Comment 4 Mark McLoughlin 2004-07-21 14:47:33 UTC
A problem is that the default suspend command is specified in a GConf
schema - hard (or at least unusual) to change a schema default
dynamically.

Might want to have two GConf keys - suspend_command_apm and
suspend_command_acpi.

Comment 5 Mark McLoughlin 2004-07-21 14:48:02 UTC
*** Bug 125562 has been marked as a duplicate of this bug. ***

Comment 6 Rik van Riel 2004-07-21 22:04:30 UTC
Mark, a good suspend command would be:

"echo 3 > /proc/acpi/sleep"

Comment 7 Mark McLoughlin 2004-08-25 22:30:10 UTC
*** Bug 130685 has been marked as a duplicate of this bug. ***

Comment 8 Havoc Pennington 2004-08-26 03:50:51 UTC
I suggest that we add a command with the following properties:

- it works for both apm and acpi systems
- users have permission to run it by default (probably using
  consolehelper so it's only console users)

and then set that as the command. Dynamically changing gconf stuff
is wonky. And we don't want to have to go around fixing everything
next time the /proc "interfaces" change ;-)

Perhaps this is just an extra flag to "shutdown"?

Unfortunately the command "suspend" already exists


Comment 9 Barry K. Nathan 2004-10-17 20:07:56 UTC
Random thought: Would "standby" be a suitable name for such a command?

Comment 10 Havoc Pennington 2004-11-03 20:55:03 UTC
Bill do you have any objection to adding such a command?


Comment 11 Bill Nottingham 2004-11-03 20:57:38 UTC
Go for it. The problem is that the semantics change, of course; the
apm suspend returns, the acpi suspend doesn't return until you resume,
etc.

Comment 12 Mark McLoughlin 2004-11-12 17:04:42 UTC
Taking off FC3 target tracker list

Comment 13 Mark McLoughlin 2004-12-20 12:30:54 UTC
Okay, spliting out a separate bug for the "we need a standby command"
into bug #143397

Comment 14 Mark McLoughlin 2005-01-05 11:03:45 UTC
*** Bug 140667 has been marked as a duplicate of this bug. ***

Comment 15 Ray Strode [halfline] 2005-04-08 21:28:51 UTC
David is actually working on a better solution to this (don't ask for a command
at all).  I'm going to reassign this bug to him.

Comment 16 David Zeuthen 2005-04-29 15:10:39 UTC
Actually, I recently filed bug 155613 for inclusion of suspend scripts. Said
scripts are a prequisite for resolving this bug.

I also got a patch for battstat-applet-2 to remove the text entry field and
provide some combo boxes for actions to take when a) lid is closed; b) suspend
button is pressed; and c) power button is pressed. 

For FC5 we'll probably just ship gnome-power-manager instead of the battstat
applet; see utopia-list@gnome.org archives for details (it's under development).

Comment 17 Ray Strode [halfline] 2005-05-11 20:31:58 UTC
Moving to FC5Target from discussion during desktop core team meeting.

Comment 18 Warren Togami 2006-03-07 22:26:06 UTC
Suspend was moved to the menu, so I guess you could call this fixed.



Note You need to log in before you can comment on or make changes to this bug.