Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 120752 - gnome-sound-recorder crashed whent press "record"
Summary: gnome-sound-recorder crashed whent press "record"
Keywords:
Status: CLOSED DUPLICATE of bug 100774
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-media
Version: rawhide
Hardware: athlon
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Colin Walters
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-04-13 18:25 UTC by schiebe
Modified: 2007-11-30 22:10 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-02-21 19:02:34 UTC


Attachments (Terms of Use)

Description schiebe 2004-04-13 18:25:36 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040312

Description of problem:
When i press record at the gnome-sound-recorder he crashes with an
Speicherzugriffsfehler. I think that means in englisch seg fault. :)

Soundcard is an ensoniq ES 1371. A another problem is that the
soundcard  dont work really good. I can hear a kind of distortions.
The Volume is not to high or something like that. 

Version-Release number of selected component (if applicable):
gnome-media-2.6.0-1

How reproducible:
Always

Steps to Reproduce:
1.Start the gnome-sound-recorder
2.press record
3.
    

Additional info:

Comment 1 petrosyan 2004-04-27 14:23:15 UTC
isn't this a duplicate of bug #100774 ?

Comment 2 schiebe 2004-04-27 14:59:15 UTC
What means "nothing happens" at your report? 
When i press the record button on my machine gets the recorder closed.
-> seg fault. 

Comment 3 Tomasz Kubacki 2004-05-19 08:24:08 UTC
I've the same problem in Fedora Core 2
I've SBLive! and it works good (i can hear my voice in speaker when i
talk to microphone)

When i press record button it says:
"segmentation fault" (in polish)



Comment 4 Eddahbi Karim 2004-05-24 01:58:51 UTC
I have the same bug but I have a different backtrace than the bug #100774.

If I launch gstreamer-properties and test the Alsa source, it fails,
with the OSS source it works AND I can hear me when I speak into the
microphone.

I can, then, use gstreamer-properties.
If I hit 'Record' it works, the sound recorded can be played but if I
hit 'Record' again, gstreamer don't save the new sound creates a 0KB
file (like the #115105 bug).

By the way, with the alsa source, I got this backtrace :

Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread 18049968 (LWP 4812)]
0x0063df74 in _int_malloc () from /lib/tls/libc.so.6
(gdb) where
#0  0x0063df74 in _int_malloc () from /lib/tls/libc.so.6
#1  0x0063d09d in malloc () from /lib/tls/libc.so.6
#2  0x0095b527 in g_malloc () from /usr/lib/libglib-2.0.so.0
#3  0x03f7f3ec in gst_buffer_new_and_alloc () from
/usr/lib/libgstreamer-0.8.so.1
#4  0x00efbe1a in gst_audio_convert_get_type () from
/usr/lib/gstreamer-0.8/libgstaudioconvert.so
#5  0x00efc8e1 in gst_audio_convert_get_type () from
/usr/lib/gstreamer-0.8/libgstaudioconvert.so
#6  0x00efacc8 in gst_audio_convert_get_type () from
/usr/lib/gstreamer-0.8/libgstaudioconvert.so
#7  0x00a31370 in ?? () from /usr/lib/gstreamer-0.8/libgstoptscheduler.so
#8  0x099d75c8 in ?? ()
#9  0x0989c33c in ?? ()
#10 0x00000001 in ?? ()
#11 0x04070088 in ?? () from /usr/lib/libgstreamer-0.8.so.1
#12 0x099d4710 in ?? ()
#13 0x04070088 in ?? () from /usr/lib/libgstreamer-0.8.so.1
#14 0x011363f8 in ?? ()
#15 0x03f9eb08 in gst_pad_push () from /usr/lib/libgstreamer-0.8.so.1
Previous frame identical to this frame (corrupt stack?) 

The program 'gnome_segv' isn't invoked by gstreamer when it crashes.

If I use 'rec', the record works so it's the software which seems buggy.

I have a VIA Audio controller chipset.
The Alsa module loaded is called 'snd-via82xx'

Comment 5 Philippe 2004-06-22 15:42:57 UTC
Fedora Core 2 : 2.6.6-1.435 / Gnome. INTEL. Ensoniq 1371
Same here, seg fault.
If you choose "Voice" quality, IT DOES NOT CRASH.
but
if you choose "CD Quality", low or high, it does.

Hope this helps.

Philippe


Comment 6 Colin Adams 2004-07-02 11:31:31 UTC
Mine crashes when I choose Voice quality. I have not tried the others.
I don't see any messages or any sort of diagnostic. Where do I look
for them?

Comment 7 Colin Walters 2004-07-27 21:21:34 UTC

*** This bug has been marked as a duplicate of 100774 ***

Comment 8 Red Hat Bugzilla 2006-02-21 19:02:34 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.