Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 120618 - invalid roff code in telnet man page
Summary: invalid roff code in telnet man page
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: krb5
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Nalin Dahyabhai
QA Contact: Brian Brock
URL:
Whiteboard:
: 145738 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-04-12 06:50 UTC by Ulrich Drepper
Modified: 2007-11-30 22:10 UTC (History)
2 users (show)

Fixed In Version: 1.3.6-3
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-02-20 20:54:36 UTC


Attachments (Terms of Use)
Patch for telnet man page (deleted)
2004-04-12 06:51 UTC, Ulrich Drepper
no flags Details | Diff

Description Ulrich Drepper 2004-04-12 06:50:52 UTC
Description of problem:
The telnet man page of the kerberos package does not display correctly
since the roff source have some extra whitespace

Version-Release number of selected component (if applicable):
krb5-workstation-1.3.2-1


How reproducible:
all the time

Steps to Reproduce:
1.man telnet
2.
3.
  
Actual results:
garbled text

Expected results:
correctly formatted text

Additional info:
I'll attach a patch.

Comment 1 Ulrich Drepper 2004-04-12 06:51:39 UTC
Created attachment 99320 [details]
Patch for telnet man page

Comment 2 Daniel Challen 2004-12-16 14:52:35 UTC
This corrupt man page is still present in Fedora Core 3 (fresh install
tested on 2 different machines, and reports from other users)
 krb5-workstation-1.3.4-7


Comment 3 Daniel Challen 2004-12-16 16:41:39 UTC
I've checked out the original manpages
(krb5-1.3.[345]/src/appl/telnet/telnet/telnet.1) in the sources from
http://web.mit.edu/kerberos/ (versions 1.3.3, 1.3.4 and 1.3.5) none of
these have the excess whitespace. It appears the bug has crept in
during the packaging for Fedora.

Comment 4 Daniel Challen 2004-12-16 17:03:17 UTC
I've checked out the original manpages
(krb5-1.3.[345]/src/appl/telnet/telnet/telnet.1) in the sources from
http://web.mit.edu/kerberos/ (versions 1.3.3, 1.3.4 and 1.3.5) none of
these have the excess whitespace. It appears the bug has crept in
during the packaging for Fedora.

Comment 6 Miloslav Trmač 2004-12-18 16:43:31 UTC
I have fixed krb5-1.3-manpage-patchs patch in CVS, so it should
be fixed in next krb5 build.

Comment 7 Ulrich Drepper 2005-02-20 20:54:36 UTC
Confirmed fixed in krb5-workstation-1.3.6-3.

Comment 8 Nalin Dahyabhai 2005-02-28 21:36:21 UTC
*** Bug 145738 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.