Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1206 - cat /proc/ioports crashes
Summary: cat /proc/ioports crashes
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kernel
Version: 5.2
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: David Lawrence
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-02-16 17:07 UTC by jm
Modified: 2008-05-01 15:37 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 1999-03-02 23:27:11 UTC


Attachments (Terms of Use)

Description jm 1999-02-16 17:07:40 UTC
Hi guys,

thx for RH 5.2, nice and stable! I've now persuaded several
mates in several companies to buy boxed copies, and they're
all pretty happy with it too. Nice one.

However, here's my problem. I've got a Yamaha OPL-3/SAX card
in my machine, along with a 3com 3c590 and an ATI 3D Rage
Pro. The net card & display work fine, but the sound is
acting up badly. It fails to load the module under
"sndconfig", and I've tried manually going through
/etc/conf.modules and "modprobe sound" etc. to work out
what's up, and after exhausting my choices of interrupts
etc. decided to install the isapnp tools to see if that
could help me set up the card.

However the isapnp tools fail to work because of the
following problem.

Before "sndconfig", "modprobe sound", or any other
sound-related module probing stuff -- basically any time
after the boot (such as in single-user mode), this is what I
get when I "cat /proc/ioports":

$ cat /proc/ioports
0000-001f : dma1
0020-003f : pic1
0040-005f : timer
[.... normal ones deleted]
0170-0177 : ide1
01f0-01f7 : ide0
0220-0221 :
Df=Q^DuS1R~@{^^"u^U~@{^_"u^O^O>C#A`^H^O>S!k^Y~Iv~@{^^wu^S~@{^_wu^M^O>C'A`^H^O>S&
B~ERt^Y~K~^X~Et^V^O7~G\^A
0376-0376 : ide1
03c0-03df : vga+
[.... and more normal stuff]

Obviously the 0220-0221 line is a bit dodgy. It gets worse
after I run "modprobe sound" or "sndconfig" (not sure why):

$ cat /proc/ioports
Segmentation fault
$

On the console, I get the following kernel messages:
Unable to handle kernel paging request at virtual address
c40353d0
current->tss.cr3 = 00824000, `r3 = 00824000
*pde = 002e3067
*pte = 00000000
Oops: 0000
CPU:    0
EIP:    0010:[pci_strvendor+1571/2372]
EFLAGS: 00010297
eax: 040353d0   ebx: ffffffff   ecx: 040353d0   edx:
fffffffe
esi: ffffffff   edi: 008530d2   ebp: 00000000   esp:
009b8edc
ds: 0018   es: 0018   fs: 002b   gs: 002b   ss: 0018
Process cat (pid: 872, process nr: 66, stackpage=009b8000)
Stack: 001d6284 000000c6 00853000 00853000 00169dea 03f7f100
03f7f100 ffffffff
       0000001b 00000007 001ac2c4 008530c6 001af14c 009b8f2c
00118b38 008530c6
       001af13d 00000220 00000221 040353d0 00000000 009b8f90
00001000 0016c12e
Call Trace: [proc_lookupfd+286/444]
[pci_strvendor+1996/2372] [do_sysctl+140/276]
[ipx+976/12288] [analyze_sb+590/840] [md_update_sb+362/440]
[do_readv_writev+424/620]
       [ret_from_sys_call+37/136]
Code: 80 38 00 74 07 40 4a 83 fa ff 75 f4 29 c8 89 c6 f7 c5
10 00


The machine keeps on going just fine -- so not a real kernel
crash at all. This is with kernel-2.0.36-3 . I've rebuilt
the kernel and the problem is still there.

I'm not sure if any other commands other than "modprobe
sound" can cause the corruption which causes that "oops"
msg, but "modprobe sound" always does it, at least.

Hope that provides enough info. Any ideas?

--j.






------- Email Received From  Justin Mason <jm@netnoteinc.com> 02/22/99 09:01 -------


------- Email Received From  Justin Mason <jm@netnoteinc.com> 03/01/99 10:24 -------


Note You need to log in before you can comment on or make changes to this bug.