Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 120460 - top does not show threaded processes properly
Summary: top does not show threaded processes properly
Keywords:
Status: CLOSED DUPLICATE of bug 116783
Alias: None
Product: Fedora
Classification: Fedora
Component: procps
Version: 2
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Daniel Walsh
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-04-08 23:20 UTC by Hrunting Johnson
Modified: 2007-11-30 22:10 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-02-21 19:02:30 UTC


Attachments (Terms of Use)

Description Hrunting Johnson 2004-04-08 23:20:16 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6)
Gecko/20040206 Firefox/0.8

Description of problem:
When viewing processes in top, threaded processes aren't displayed
correctly.  Either a) the threads should be shown individually or b)
the threaded process should show the combined statistics of all
threads.  Currently, only the statistics for the parent thread are
shown.  Since parent threads are often just signal listeners,
multi-threaded processes that consume lots of CPU often show up as not
consuming any.

Previously, the H option inside top would show all threads, but that
was before NPTL and the single-PID thread model.

Solaris' top gives you an option to display either mode.

Version-Release number of selected component (if applicable):
procps-3.1.15-3

How reproducible:
Always

Steps to Reproduce:
1. start threaded process
2. start top
3.
    

Actual Results:  Top displays only the CPU statistics (memory looks
okay) for the parent thread, not all threads (either individually or
summed)

Expected Results:  Top displays the CPU statistics for all threads,
either individually or summed.

Additional info:

A good example of a process that exhibits this behavior is Cyclone
from Highwinds Software.

Comment 1 Peter Oliver 2004-07-22 22:13:11 UTC
I notice that this is a duplicate of 116783, but bugzilla won't let me
mark it as such.

Comment 2 Albert Cahalan 2004-07-28 15:30:56 UTC
How does a user select behavior on Solaris?
(which key and/or option)

Comment 3 Eric Paris 2004-08-15 01:01:34 UTC

*** This bug has been marked as a duplicate of 116783 ***

Comment 4 Red Hat Bugzilla 2006-02-21 19:02:30 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.