Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1201000 - RFE: print channel name in addition to code in 'info spice'
Summary: RFE: print channel name in addition to code in 'info spice'
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: qemu-kvm
Version: 7.2
Hardware: Unspecified
OS: Unspecified
low
low
Target Milestone: rc
: ---
Assignee: Cole Robinson
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On: 822418
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-03-11 19:22 UTC by Cole Robinson
Modified: 2015-08-31 21:20 UTC (History)
21 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Clone Of: 822418
Environment:
Last Closed: 2015-08-31 21:20:55 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Cole Robinson 2015-03-11 19:22:23 UTC
+++ This bug was initially created as a clone of Bug #822418 +++

Description of problem:
add channel name to 'info spice' output. Current implementation shows just channel codes like 1:0, printing of channel name there would make some debugging & verifcations easier.

Version-Release number of selected component (if applicable):
spice-server-0.10.1-9.el6.x86_64

How reproducible:
always

Steps to Reproduce:
1. run: qemu-kvm -monitor stdio -spice port=5900
2. connect to the qemu with client
3. type into qemu monitor: info spice
  
Actual results:
output like this is printed:
Server:
     address: 0.0.0.0:5800
        auth: none
Channel:
     address: 127.0.0.1:33058
     session: 1804289383
     channel: 1:0
(...)

Expected results:
Server:
     address: 0.0.0.0:5800
     address: 0.0.0.0:5801 [tls]
        auth: none
Channel:
     address: 127.0.0.1:33058
     session: 1804289383
     channel: 1:0
     name: main

Additional info:

--- Additional comment from David Jaša on 2012-06-26 10:03:23 EDT ---

Looking into the code, it looks more like qemu RFE than spice-server one. Qemu monitor output is defined in qemu's hmp.c while spice channel codes are defined in spice-protocol and spice-server respectively:

http://cgit.freedesktop.org/spice/spice-protocol/tree/spice/enums.h#n337
http://cgit.freedesktop.org/spice/spice/tree/server/reds.c#n3959

--- Additional comment from RHEL Product and Program Management on 2012-07-10 01:47:32 EDT ---

This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.

--- Additional comment from RHEL Product and Program Management on 2012-07-10 22:01:57 EDT ---

This request was erroneously removed from consideration in Red Hat Enterprise Linux 6.4, which is currently under development.  This request will be evaluated for inclusion in Red Hat Enterprise Linux 6.4.

--- Additional comment from David Blechter on 2012-10-15 13:52:00 EDT ---

Too late for 6.4, moving to 6.5, not a blocker

--- Additional comment from Ludek Smid on 2013-03-07 09:55:52 EST ---

Since the release flag was set to ? after the qa_ack and pm_ack and devel_ack flags were set to + (was likely set for the previous release), the qa_ack and pm_ack and devel_ack flags have been reset to ? by the bugbot (pm-rhel). This action ensures the proper review by Product Management.

--- Additional comment from RHEL Product and Program Management on 2013-10-14 01:00:03 EDT ---

This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.

--- Additional comment from Marc-Andre Lureau on 2014-06-18 13:54:39 EDT ---

this is more a qemu rfe actually.

The HMP prints chan->value->channel_type, the channel type is defined by the protocol. Arguably, spice server could provide a spice_channel_type_to_string() but I don't think that's really necessary here. 

moving to 6.7

--- Additional comment from Cole Robinson on 2015-02-26 14:36:11 EST ---

Patch posted upstream:

https://lists.gnu.org/archive/html/qemu-devel/2015-02/msg05163.html

--- Additional comment from Cole Robinson on 2015-03-02 12:13:25 EST ---

v3 here was applied to gerd's queue:

https://lists.gnu.org/archive/html/qemu-devel/2015-03/msg00009.html

Comment 1 Cole Robinson 2015-08-10 23:47:58 UTC
My feeling here is that while it's 'nice to have' its not even worth the effort of backporting to RHEL7 qemu-kvm. So I think we should just close this

Comment 2 Cole Robinson 2015-08-31 21:20:55 UTC
Closing as I suggested in Comment #1


Note You need to log in before you can comment on or make changes to this bug.