Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1194790 - Internal Server Error when adding ~10 or more systems to channel from channel's Target Systems tab
Summary: Internal Server Error when adding ~10 or more systems to channel from channel...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Spacewalk
Classification: Community
Component: Server
Version: 2.2
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Tomáš Kašpárek
QA Contact: Red Hat Satellite QA List
URL:
Whiteboard:
Depends On:
Blocks: 465198 sat560-triage space23
TreeView+ depends on / blocked
 
Reported: 2015-02-20 18:22 UTC by Tasos Papaioannou
Modified: 2015-04-14 19:03 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of: 1175939
Environment:
Last Closed: 2015-04-14 19:03:36 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Bugzilla 1175939 None None None Never

Description Tasos Papaioannou 2015-02-20 18:22:01 UTC
Created attachment 994030 [details]
Patch

+++ This bug was initially created as a clone of Bug #1175939 +++

Description of problem:

When subscribing systems to a channel from the channel's Target Systems tab, each system is processed in turn, and each system's errata cache is updated synchronously. For even a relatively small number of systems, the web UI takes several minutes to complete the action, and returns an Internal Server Error because the session timeout has been exceeded. Reproduced internally with 10 systems subscribed to rhn-tools-rhel-x86_64-server-6, which hung for 3.5 minutes before returning an ISE.

Version-Release number of selected component (if applicable):

spacewalk-java-2.0.2-92.el6sat.noarch

How reproducible:

100%

Steps to Reproduce:
1.) See Description above.

Actual results:

Long delay after submitting action, followed by ISE.

Expected results:

No ISE, submitted action completes quickly.

Additional info:

Changing the subscribe_server_to_channel query in ./java/code/src/com/redhat/rhn/common/db/datasource/xml/Channel_queries.xml to regenerate the errata cache asynchronously reduced the time from 3.5 minutes to 20 seconds (with no ISE) for the reproducer mentioned above. Proposed patch attached.

Comment 1 Tasos Papaioannou 2015-02-20 18:46:01 UTC
BZ 1194790 regenerate errata cache asynchronously when subscribing server to channel #225
https://github.com/spacewalkproject/spacewalk/pull/225

Comment 2 Tomáš Kašpárek 2015-02-26 12:18:50 UTC
Committed patch into Spacewalk: e8c453fe00dc8ef56851e8dfe39cda043144a594

Comment 3 Grant Gainey 2015-03-23 16:59:19 UTC
Moving bugs to ON_QA as we move to release Spacewalk 2.3

Comment 4 Grant Gainey 2015-04-14 19:03:36 UTC
Spacewalk 2.3 has been released. See

https://fedorahosted.org/spacewalk/wiki/ReleaseNotes23


Note You need to log in before you can comment on or make changes to this bug.