Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 119311 (i8xx-drm) - [i845 drm] X lockup with 3D screensaver
Summary: [i845 drm] X lockup with 3D screensaver
Alias: i8xx-drm
Product: Fedora
Classification: Fedora
Component: kernel
Version: rawhide
Hardware: i686
OS: Linux
Target Milestone: ---
Assignee: Arjan van de Ven
QA Contact:
: 121846 (view as bug list)
Depends On:
Blocks: FC2Target
TreeView+ depends on / blocked
Reported: 2004-03-29 11:09 UTC by vvs
Modified: 2007-11-30 22:10 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Last Closed: 2004-05-05 15:51:00 UTC

Attachments (Terms of Use)
DRM messages (deleted)
2004-03-29 11:10 UTC, vvs
no flags Details
Xserver messages (deleted)
2004-03-29 11:10 UTC, vvs
no flags Details
Xserver configuration (deleted)
2004-03-29 11:11 UTC, vvs
no flags Details
DRM messages (deleted)
2004-04-09 13:06 UTC, vvs
no flags Details
Xserver messages (deleted)
2004-04-09 13:08 UTC, vvs
no flags Details

Description vvs 2004-03-29 11:09:03 UTC
Description of problem:

3D screensaver caused lockup of Xserver. My configuration:

Compaq Evo D310vm
Intel 845G

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. run xscreensaver-demo
2. select any 3D screensaver (e.g. AntSpotlight)
Actual results:

Xserver locks-up

Expected results:

Shouldn't be

Additional info:

This happens 100% with the latest Arjan's kernel and sporadically
happened with older kernels. It happen with latest xorg-x11 and with
older XFree86 releases too. That makes use of 3D graphics with Intel
8x5G chipsets impossible with 2.6 kernel.

There were similar bug reports in bugzilla:

But they lack some information and I prefer to open it as new with
logs attached.

Comment 1 vvs 2004-03-29 11:10:10 UTC
Created attachment 98919 [details]
DRM messages

Comment 2 vvs 2004-03-29 11:10:39 UTC
Created attachment 98920 [details]
Xserver messages

Comment 3 vvs 2004-03-29 11:11:14 UTC
Created attachment 98921 [details]
Xserver configuration

Comment 4 Arjan van de Ven 2004-04-06 10:31:35 UTC
I fixed one bug in the i830 drm code (doubtless there are more); do
later kernels work better for you ?

Comment 5 vvs 2004-04-07 07:31:17 UTC
Nope :-( The same story.


Comment 6 vvs 2004-04-09 09:48:37 UTC
Latest kernel hit the spot :-) It works now.


I will watch if that bug won't show again sporadically and I'll report
it here later.

Comment 7 vvs 2004-04-09 13:03:36 UTC
Unfortunately it still locks-up sometimes during Xserver startup. But
it's not related to 3D screensaver anymore and it's fairly usable now.
I've attached new logs.

Comment 8 vvs 2004-04-09 13:06:30 UTC
Created attachment 99265 [details]
DRM messages

Comment 9 vvs 2004-04-09 13:08:56 UTC
Created attachment 99266 [details]
Xserver messages

Comment 10 vvs 2004-04-15 10:39:04 UTC
Well, recent kernels broke it again:


But now it locks-up cold, I can't even shutdown system cleanly.
Hitting power button don't work anymore as it did before (I have
acpi=on and acpid running). And so it was not possible to get log
messages because they were lost.

Comment 11 Alan Cox 2004-05-03 15:44:02 UTC
*** Bug 121846 has been marked as a duplicate of this bug. ***

Comment 12 vvs 2004-05-04 12:59:35 UTC
Unfortunately it doesn't work with kernel-2.6.5-1.349 either, sorry.

Comment 13 Arjan van de Ven 2004-05-04 17:14:48 UTC
ok 350 has this fixed 99% sure; I found out my testbox actually has a
865 chip which gets visible when I remove the AGP radeon ...

Comment 14 vvs 2004-05-05 13:30:01 UTC
Yes, you are right, kernel-2.6.5-1.350 actually has this fixed. Thank
you very much!

Comment 15 Alan McKay 2004-08-04 00:25:23 UTC
I'm running Fedora Tettnang release as downloaded 2 weeks ago, and
this problem still seems to be there except it comes up more randomly.
 And given that I run the machine 24x7 and have only seen the problem
when the saver kicks in, I have to assume that it only locks up the
machine if you try to use the machine while the particular SS is
active.  i.e. if you let the problem SS run it's course (e.g. while
I'm gone all day) and let the next one start, it's fine.  Maybe that's
an invalid assumption.

I've had it happen twice now.  Sorry, don't recall which saver it was
either time.  First time when I moved the mouse to deactive the saver
text appeared in the top left of the screen.  i.e. it was console text
coming out over top of the X server as though X were not even running
if you get what I mean.  I could still move the mouse and alt-tab
windows - for a bit.  Then things locked up completely.  But when I
hit the power button X came down and then I had the regular clean
Linux shutdown with all the "blah blah blah ..... [OK]"

The second time was just a few minutes ago and there was no console
text coming through, and it was hung tight from the beginning and the
power button seemed to initiate a shutdown but I didn't get all the
"blah blah blah ..... [OK]" - a few lines of shutdown text came up
then the power went out.  On reboot filesystems were clean though.

I've got an Nvidea Gforce (440 I think) video card, and an ASUS mobo
either  A7N8X-X or A7V8X-X don't recall of the top of my head.  

Dunno if this should reopen this bug or if there is somewhere else for
this to go. My apologies if I did the wrong thing but this was the
closest I could find.

Comment 16 Eric Raymond 2004-11-13 22:54:41 UTC
I'm seeing what looks like the same problem (X lockup on 3D
screensaver) under a stock FC3 with a 2.6.9 kernel, ATI Radeon card.
It did not occur under FC2.

Note You need to log in before you can comment on or make changes to this bug.