Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 118780 - Requires(pre,postun) is ignored for installed packages
Summary: Requires(pre,postun) is ignored for installed packages
Keywords:
Status: CLOSED DUPLICATE of bug 155700
Alias: None
Product: Fedora
Classification: Fedora
Component: rpm
Version: rawhide
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Paul Nasrat
QA Contact: Mike McLean
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-03-20 06:17 UTC by Michael Schwendt
Modified: 2007-11-30 22:10 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-04-23 00:10:53 UTC


Attachments (Terms of Use)

Description Michael Schwendt 2004-03-20 06:17:13 UTC
Installed is a package which "Requires(pre,postun): foo". 

$ rpm -qR test | grep foo
foo

However:

$ rpm -q --whatrequires foo
no package requires foo

And I can "rpm -e foo" and the %postun scriptlet in the installed
package fails. Like in Enrico's bug 118773 report, splitting the
requirements to

Requires(pre): foo
Requires(post): foo

fixes this, and "foo" shows up in upon "--whatrequires foo" query, too.


Version-Release number of selected component (if applicable):
rpm-4.3-0.21 (and rpm-4.2.1-0.30)

How reproducible:
Always

Additional info:
I'm prepared to hear this is a feature, not a bug. ;)

Comment 1 Jeff Johnson 2004-03-20 15:39:00 UTC
Ok, it's a "feature" not a bug.

You have known and adequate workaround. I suggest you use that.

Comment 2 Leonard den Ottolander 2004-04-13 14:08:15 UTC
*** Bug 118773 has been marked as a duplicate of this bug. ***

Comment 3 Mike A. Harris 2005-04-22 13:13:10 UTC
This is not a feature.  It is a bug.  RPM documentation clearly states
that the syntax:  Requires(foo,bar) is valid.  Fix rpm.


Comment 4 Warren Togami 2005-04-22 22:19:06 UTC
*boink*


Comment 5 Leonard den Ottolander 2005-04-22 22:30:03 UTC
??

Comment 6 Paul Nasrat 2005-04-23 00:09:14 UTC
See bug #155700 which I'll close as a dupe of this for details of issue.  I've
tested a fix - basically a test that is incorrect in (pre,postun) cases and I'll
get a testing package out next week.  

Comment 7 Paul Nasrat 2005-04-23 00:10:53 UTC
Sorry easier closing this way around - as other bug is on blockers.  

*** This bug has been marked as a duplicate of 155700 ***


Note You need to log in before you can comment on or make changes to this bug.