Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 118773 - Requires(pre,postun) screws up package ordering
Summary: Requires(pre,postun) screws up package ordering
Keywords:
Status: CLOSED DUPLICATE of bug 155700
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: rpm
Version: 1.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Paul Nasrat
QA Contact:
URL:
Whiteboard: triage|leonardjo|closed|duplicate
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-03-20 00:08 UTC by Enrico Scholz
Modified: 2007-04-18 17:04 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-04-25 18:37:53 UTC


Attachments (Terms of Use)
spec-file (deleted)
2004-03-20 00:09 UTC, Enrico Scholz
no flags Details

Description Enrico Scholz 2004-03-20 00:08:49 UTC
Description of problem:

# rpm -Uvh test-*0-1.noarch.rpm
Preparing...                ########################################### [100%]
   1:test-B                 ########################################### [ 33%]
   2:test                   ########################################### [ 67%]
   3:test-A                 ########################################### [100%]


Expected would be that 'test-A' gets installed before 'test'. The
trigger seems to be the 'postun' Requires; without it, things are
fine.


Version-Release number of selected component (if applicable):

rpm-4.2-0.69 - rpm-4.3-0.21


How reproducible:

100%



Additional information:

-vvvv output is

: ========== +++ test-0-1 noarch/linux 0x0
D: opening  db index       /var/lib/rpm/Depends create mode=0x0
D:  Requires: test-A                                        YES (added provide)
D:  Requires: rpmlib(PayloadFilesHavePrefix) <= 4.0-1       YES (rpmlib provides)
D:  Requires: rpmlib(CompressedFileNames) <= 3.0.4-1        YES (rpmlib provides)
D: opening  db index       /var/lib/rpm/Conflictname rdonly mode=0x0
D: ========== +++ test-A-0-1 noarch/linux 0x0
D:  Requires: rpmlib(PayloadFilesHavePrefix) <= 4.0-1       YES (cached)
D:  Requires: rpmlib(CompressedFileNames) <= 3.0.4-1        YES (cached)
D: ========== +++ test-B-0-1 noarch/linux 0x0
D:  Requires: rpmlib(PayloadFilesHavePrefix) <= 4.0-1       YES (cached)
D:  Requires: rpmlib(CompressedFileNames) <= 3.0.4-1        YES (cached)
D: closed   db index       /var/lib/rpm/Depends
D: ========== recording tsort relations
D: ========== tsorting packages (order, #predecessors, #succesors, tree, depth)
D:     0    0    0    2    0 +test-B-0-1
D: ========== successors only (1293 bytes)
D:     1    0    0    0    0 +test-0-1
D:     2    0    0    1    0 +test-A-0-1

Comment 1 Enrico Scholz 2004-03-20 00:09:32 UTC
Created attachment 98702 [details]
spec-file

Comment 2 Enrico Scholz 2004-03-20 00:17:44 UTC
When writing

| Requires(pre):    test-A
| Requires(postun): test-A

instead of

| Requires(pre,postun):  test-A

things are fine too.

Comment 3 Robert Scheck 2004-03-20 17:50:18 UTC
Maybe your problem it's related with: #118780

Comment 4 Leonard den Ottolander 2004-04-13 14:08:11 UTC
Yes, duplicate of bug 118780. Closing as such.


*** This bug has been marked as a duplicate of 118780 ***

Comment 5 Leonard den Ottolander 2004-04-13 14:32:33 UTC
Not the same issue according to mschwendt. Reopening.


Comment 6 Mike A. Harris 2005-04-25 18:37:53 UTC

*** This bug has been marked as a duplicate of 155700 ***

Comment 7 Fedora Update System 2005-09-16 21:24:50 UTC
From User-Agent: XML-RPC

xorg-x11-6.8.2-1.FC3.45 has been pushed for FC3, which should resolve this issue.  If these problems are still present in this version, then please make note of it in this bug report.



Note You need to log in before you can comment on or make changes to this bug.