Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1185 - Apache DSO Not Working
Summary: Apache DSO Not Working
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: mod_php3
Version: 6.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: David Lawrence
QA Contact:
URL:
Whiteboard:
: 1186 1187 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-02-16 00:26 UTC by Thornton Prime
Modified: 2008-05-01 15:37 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 1999-03-31 20:06:22 UTC


Attachments (Terms of Use)

Description Thornton Prime 1999-02-16 00:26:11 UTC
The Apache SHARED_CHAIN doesn't seem to be working properly
or something.

Trying to run mod_php3 as a DSO from Apache result in the
following error ...

Cannot load /etc/httpd/modules/libphp3.so into server:
/etc/httpd/modules/libphp3.so: undefined symbol: gdbm_errno

mod_perl scripts that load native code dump SEGV.

Comment 1 Bill Nottingham 1999-02-16 15:35:59 UTC
*** Bug 1187 has been marked as a duplicate of this bug. ***

The Apache SHARED_CHAIN doesn't seem to be working properly
or something.

Trying to run mod_php3 as a DSO from Apache result in the
following error ...

Cannot load /etc/httpd/modules/libphp3.so into server:
/etc/httpd/modules/libphp3.so: undefined symbol: gdbm_errno

mod_perl scripts that load native code dump SEGV.

Comment 2 Bill Nottingham 1999-02-16 15:36:59 UTC
*** Bug 1186 has been marked as a duplicate of this bug. ***

The Apache SHARED_CHAIN doesn't seem to be working properly
or something.

Trying to run mod_php3 as a DSO from Apache result in the
following error ...

Cannot load /etc/httpd/modules/libphp3.so into server:
/etc/httpd/modules/libphp3.so: undefined symbol: gdbm_errno

mod_perl scripts that load native code dump SEGV.

Comment 3 Thornton Prime 1999-02-16 19:14:59 UTC
It is a mod_php3 bug. It appears that the configure script does not
correctly link against the required LIBS when using APXS. I will
modify and submit a patch.

Comment 4 Preston Brown 1999-03-31 20:06:59 UTC
mod_php3-3.0.7-3 and apache-1.3.6-4 have been tested and are known to
play well together.


Note You need to log in before you can comment on or make changes to this bug.