Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 118361 - xpdf will not show some legitimate pdf files
Summary: xpdf will not show some legitimate pdf files
Alias: None
Product: Fedora
Classification: Fedora
Component: xpdf
Version: rawhide
Hardware: All
OS: Linux
Target Milestone: ---
Assignee: Ngo Than
QA Contact: Mike McLean
Depends On:
TreeView+ depends on / blocked
Reported: 2004-03-15 23:00 UTC by Michal Jaegermann
Modified: 2007-11-30 22:10 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Last Closed: 2004-10-26 14:36:32 UTC

Attachments (Terms of Use)

Description Michal Jaegermann 2004-03-15 23:00:06 UTC
Description of problem:
I encountered a file (Han The Thanh thesis on a typography)
which does not display in xpdf.  This is not entirely true
as some fragments, or even pages, do show up but a bulk of
this file is not visible.

The same file when fed to ggv shows up without any trouble.
Also an older copy of acroread I happened to have around
is happy with it.

Version-Release number of selected component (if applicable):
xpdf-3.00-3 but the same actually happens with xpdf-2.x
(used with on a Linux installation other than FC2t1).

How reproducible:

The pdf file is attached to this report.

Comment 1 Michal Jaegermann 2004-03-15 23:09:20 UTC
The pdf file is NOT attached, because it turns out to be over
a bugzilla limit, but it can be found, for example, here:

Comment 2 Ngo Than 2004-04-08 12:31:06 UTC
it looks like a rendering problem in xpdf

Comment 3 Michal Jaegermann 2004-04-08 15:48:18 UTC
> it looks like a rendering problem in xpdf
Indeed. :-)  I reported the issue to but so far
I did not hear any comments.  BTW - Han The Thanh is explicitely
acknowledged in README for xpdf which makes that even more curious.

Comment 4 Michal Jaegermann 2004-04-15 22:07:31 UTC
Trying to display the file in question with a help of an option
'-t1lib no' (as suggested by the xpdf author) results in the following

Warning: Cannot convert string
"-*-times-medium-r-normal--16-*-*-*-*-*-iso8859-1" to type FontStruct
Error: Couldn't create a font for 'FDKWUW+ITCGaramondMM_500_500_'
Error: Couldn't create a font for 'HEGTAN+ITCGaramondMM_370_500_'
Error: Couldn't create a font for 'FDKWUW+ITCGaramondMM_500_500_'
Error: Couldn't create a font for 'HEGTAN+ITCGaramondMM_370_500_'
Error: Couldn't create a font for 'FDKWUW+ITCGaramondMM_500_500_'
Error: Couldn't create a font for 'HEGTAN+ITCGaramondMM_370_500_'

display results do not differ from what was before and after few
pages the whole program freezes and has to be killed with '-9'
signal.  The same source recompiled on Rh7.3 instalation does not
behave any better with this particular file but at least xpdf
does NOT locks up when called with '-t1lib no'.

Comment 5 Sammy 2004-07-15 18:47:16 UTC
Could this be due to T!lib-5.0.2 rather than t1lib-1.3.1? When I  
tried kpdf, which is based on xpdf 2.0x it is able to show the 
above document! 

Comment 6 Michal Jaegermann 2004-08-04 16:37:07 UTC
gpdf-2.7.2-1 from rawhide has the same trouble.  It is even worse
because it does not gives any indication that there are any
pages in the document.  One is starring at a blank page with
no controls whatsoever beyond "Open".

Comment 7 Michal Jaegermann 2004-10-19 04:43:14 UTC
'xpdf -t1lib no -freetype yes -aa yes ....' shows the file in question
at least on FC3test3.

Comment 8 Ngo Than 2004-10-26 14:36:32 UTC
Michal, i now disable t1lib in xpdf-3.00-11 and just use freetype2 for
font rendering. freetype2 can render Type1 fonts as well and the above
pdf document will be displayed correctly.

I think t1lib should be removed and we can close the bug ;-)

Comment 9 Michal Jaegermann 2004-10-26 16:34:52 UTC
I have no idea if freetype2 can render the same fonts as t1lib
and from which version.  What I wrote in comment #7 worked for me
on this particular file _and_ in fc3.  I tried the same trick,
i.e. 'xpdf -t1lib no -freetype yes ...' with an earlier version
of freetype (freetype-2.0.9 which is not freetype2, I think) and
got only:

Error: Couldn't create a font for 'FDKWUW+ITCGaramondMM_500_500_'
Error: Couldn't create a font for 'HEGTAN+ITCGaramondMM_370_500_'
Error: Couldn't create a font for 'FDKWUW+ITCGaramondMM_500_500_'

for my trouble and no text on a display.

OTOH a very unscientific test on few other PDF files which I had
laying around seem to indicate that this is not worse than
with t1lib in use.

You do not have to kick out t1lib entirely.  It seems that it would
be enough to put in this 'sample-xpdfrc', or however this is called,
'enableT1lib no'.  This gets installed as /etc/xpdfrc (unless you
have it 'noreplace' now?) and if somebody really needs t1lib then
they can enable it there.  This is possibly too paranoid.

Note You need to log in before you can comment on or make changes to this bug.