Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1178937 - e2label fails to label root filesystem (failed to set bootloader)
Summary: e2label fails to label root filesystem (failed to set bootloader)
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-node
Version: 3.5.0
Hardware: Unspecified
OS: Unspecified
urgent
urgent
Target Milestone: ---
: 3.5.0
Assignee: Fabian Deutsch
QA Contact: Virtualization Bugs
URL:
Whiteboard: node
Depends On:
Blocks: rhev35rcblocker rhev35gablocker
TreeView+ depends on / blocked
 
Reported: 2015-01-05 17:11 UTC by Fabian Deutsch
Modified: 2016-02-10 20:05 UTC (History)
13 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-02-11 21:07:40 UTC
oVirt Team: Node
Target Upstream Version:


Attachments (Terms of Use)
ovirt.log from a failed attempt (deleted)
2015-01-05 17:11 UTC, Fabian Deutsch
no flags Details
Some command outputs (deleted)
2015-01-05 17:11 UTC, Fabian Deutsch
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2015:0160 normal SHIPPED_LIVE ovirt-node bug fix and enhancement update 2015-02-12 01:34:52 UTC
oVirt gerrit 36594 master MERGED ovirtfunctions: Remove all partporbe/kpartx calls Never
oVirt gerrit 36596 ovirt-3.5 MERGED ovirtfunctions: Remove all partporbe/kpartx calls Never

Description Fabian Deutsch 2015-01-05 17:11:20 UTC
Created attachment 976523 [details]
ovirt.log from a failed attempt

Description of problem:
The installation fails with "Failed to set install bootloader", but it actually fails to label the root filesystem.

Version-Release number of selected component (if applicable):
rhev-hypervisor7-7.0-20150105.0.1

How reproducible:
sometimes

Steps to Reproduce:
1. Create a VM with a multipathed disk on a SATA bus
2. Install RHEV-H
3.

Actual results:
Installation failes

Expected results:
Installation completes


Additional info:

Comment 1 Fabian Deutsch 2015-01-05 17:11:44 UTC
Created attachment 976525 [details]
Some command outputs

Comment 4 haiyang,dong 2015-01-06 11:05:50 UTC
I tried this case about ten times, couldn't reproduce it in rhev-hypervisor7-7.0-20150105.0.

Test steps:
1. Create a VM with a multipathed disk on a SATA bus(Create two disks in virt manager, pointing to the same disk image, and both disks need the same serial
number)
2. Install RHEV-H

Comment 5 Ying Cui 2015-01-07 16:18:10 UTC
According to comment 4, Virt QE tested 10 times, can not reproduce it, so far we can not easy qa_ack+. it's related probability bug.
What is standard to verify this bug? How many test execution if can not reproduce this bug, then this bug can safe verified?

Comment 6 Fabian Deutsch 2015-01-08 19:36:51 UTC
10 times is good number of tries. Especially when it was tried on different hardware.

This bug is a race, so it is hard to reproduce.
I'd say, if you not encounter any "failed to install bootlader" message in your testing, then we can see this bug as verified.

Comment 9 Ying Cui 2015-01-26 07:53:30 UTC
haiyang, please verify this bug according to comment 6.

here i pasted my test comment here FYI only:
Tested on z600-03, 3 times on TUI installation with rhev-hypervisor7-7.0-20150114.0, all successful, no encounter failed to set bootloader error.

Comment 10 haiyang,dong 2015-01-29 13:08:31 UTC
Test version:
rhev-hypervisor7-7.0-20150127.0.iso
ovirt-node-3.2.1-6.el7.noarch

Test steps:
1. Create a VM with a multipathed disk on a SATA bus(Create two disks in virt manager, pointing to the same disk image, and both disks need the same serial
number)
2. Install RHEV-H

I still couldn't reproduce it in rhev-hypervisor7-7.0-20150127.0.iso and also according to Comment 9, verified this bug.

Comment 12 errata-xmlrpc 2015-02-11 21:07:40 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2015-0160.html


Note You need to log in before you can comment on or make changes to this bug.