Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1174146 - [6.6_3.5] Failed to install hypervisor on cciss machine.
Summary: [6.6_3.5] Failed to install hypervisor on cciss machine.
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-node
Version: 3.5.0
Hardware: Unspecified
OS: Unspecified
urgent
urgent
Target Milestone: ---
: 3.5.0
Assignee: Fabian Deutsch
QA Contact: Virtualization Bugs
URL:
Whiteboard: node
Depends On:
Blocks: rhev35rcblocker rhev35gablocker
TreeView+ depends on / blocked
 
Reported: 2014-12-15 09:12 UTC by cshao
Modified: 2016-02-10 20:05 UTC (History)
13 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-02-11 21:06:56 UTC
oVirt Team: Node
Target Upstream Version:


Attachments (Terms of Use)
tmp-ovirt.log (deleted)
2014-12-15 09:12 UTC, cshao
no flags Details
cciss-auto-failed.png (deleted)
2014-12-15 09:15 UTC, cshao
no flags Details
1212-cciss.tar.gz (deleted)
2014-12-16 14:12 UTC, cshao
no flags Details
new1212.tar.gz (deleted)
2014-12-18 01:56 UTC, cshao
no flags Details
sosreport log for comment13 (deleted)
2014-12-19 13:18 UTC, Ying Cui
no flags Details
sosreport for comment 14 (deleted)
2014-12-19 13:20 UTC, Ying Cui
no flags Details
/tmp/log for comment 14 (deleted)
2014-12-19 13:21 UTC, Ying Cui
no flags Details
step1 (deleted)
2014-12-19 13:22 UTC, Ying Cui
no flags Details
cciss_step2 (deleted)
2014-12-19 13:23 UTC, Ying Cui
no flags Details
cciss_step3 (deleted)
2014-12-19 13:24 UTC, Ying Cui
no flags Details
cciss_step4 (deleted)
2014-12-19 13:25 UTC, Ying Cui
no flags Details
var.log.tar.gz (deleted)
2014-12-23 03:29 UTC, cshao
no flags Details
ccisslog.tar.gz (deleted)
2014-12-24 10:42 UTC, cshao
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2015:0160 normal SHIPPED_LIVE ovirt-node bug fix and enhancement update 2015-02-12 01:34:52 UTC
oVirt gerrit 36365 None MERGED installer: Use different size source Never
oVirt gerrit 36395 master MERGED Correct path for non-mpath cciss devices Never
oVirt gerrit 36416 master MERGED installer: Don't use multipath for /dev/cciss Never
oVirt gerrit 36562 ovirt-3.5 MERGED Correct path for non-mpath cciss devices Never
oVirt gerrit 36563 ovirt-3.5 MERGED installer: Don't use multipath for /dev/cciss Never

Comment 1 cshao 2014-12-15 09:12:37 UTC
Created attachment 968832 [details]
tmp-ovirt.log

Comment 2 cshao 2014-12-15 09:15:02 UTC
Created attachment 968834 [details]
cciss-auto-failed.png

Comment 3 Fabian Deutsch 2014-12-15 09:57:23 UTC
Can you please also provide /tmp/ovirt.log?

Comment 4 cshao 2014-12-15 10:01:47 UTC
Hi fabiand,

All log already uploaded.
/var/log/*.(
/tm/ovirt.log

Please see #c 1.

Thanks!

Comment 5 Fabian Deutsch 2014-12-15 10:17:05 UTC
Thanks!

Can we also get access to that machine?

Comment 6 Fabian Deutsch 2014-12-15 10:24:56 UTC
There are many errors in the log:

Buffer I/O error on device cciss/c0d0, logical block 1
Buffer I/O error on device cciss/c0d0, logical block 2
cciss 0000:50:08.0: cmd ffff88007fac0280 has CHECK CONDITION sense key = 0x3

…

Buffer I/O error on device sr0, logical block 118589
Buffer I/O error on device sr0, logical block 118590
Buffer I/O error on device sr0, logical block 118591
Buffer I/O error on device sr0, logical block 118592
Buffer I/O error on device sr0, logical block 118593
Buffer I/O error on device sr0, logical block 118594
Buffer I/O error on device sr0, logical block 118595
Buffer I/O error on device sr0, logical block 118596
Buffer I/O error on device sr0, logical block 118597
SQUASHFS error: squashfs_read_data failed to read block 0xa9ced39
SQUASHFS error: Unable to read data cache entry [a9ced39]
SQUASHFS error: Unable to read page, block a9ced39, size 12065
SQUASHFS error: Unable to read data cache entry [a9ced39]
SQUASHFS error: Unable to read page, block a9ced39, size 12065


Please verify:

+ That the ISO is not corrupted
+ That the hardware is okay
+ That RHEL can boot and no errors are in dmesg

Comment 8 cshao 2014-12-16 14:12:08 UTC
Created attachment 969581 [details]
1212-cciss.tar.gz

Comment 9 Fabian Deutsch 2014-12-17 11:46:41 UTC
The cause for this bug is an incorrect multipath configuration.

It seems that some of our changes, collide with changes from other packages.

Comment 10 Fabian Deutsch 2014-12-17 15:08:49 UTC
One way to rule out the error source network: Can you please try to reproduce this bug which a USB media install?

Comment 12 cshao 2014-12-18 01:56:52 UTC
Created attachment 970366 [details]
new1212.tar.gz

Comment 14 Fabian Deutsch 2014-12-19 12:01:33 UTC
Chen, comment 13 does not help me at all.

I need logs!
dmesg, /var/log/messages /var/log* ... Otehrwise I can not help.

Also: It seems as if the test env is on the cciss machine, and it is installed. Could you please elaborate and explain a bit more why this is, if you say that it fails to instzall on a cciss machine?

Comment 15 Ying Cui 2014-12-19 13:18:34 UTC
Created attachment 971148 [details]
sosreport log for comment13

Comment 16 Ying Cui 2014-12-19 13:19:30 UTC
Fabian, I setup another new CCISS machine to grab the new logs and paste here the one by one steps on pic. see the below: sosreport-hp-bl465cg5-01-20141219130528-b2da.tar.xz, cciss_step1/step2/step3/setep4.

Comment 17 Ying Cui 2014-12-19 13:20:47 UTC
Created attachment 971149 [details]
sosreport for comment 14

Comment 18 Ying Cui 2014-12-19 13:21:34 UTC
Created attachment 971150 [details]
/tmp/log for comment 14

Comment 19 Ying Cui 2014-12-19 13:22:59 UTC
Created attachment 971151 [details]
step1

Comment 20 Ying Cui 2014-12-19 13:23:56 UTC
Created attachment 971152 [details]
cciss_step2

Comment 21 Ying Cui 2014-12-19 13:24:22 UTC
Created attachment 971153 [details]
cciss_step3

Comment 22 Ying Cui 2014-12-19 13:25:03 UTC
Created attachment 971155 [details]
cciss_step4

error happend

Comment 24 cshao 2014-12-22 06:19:40 UTC
(In reply to Fabian Deutsch from comment #14)
> Chen, comment 13 does not help me at all.
> 
> I need logs!
> dmesg, /var/log/messages /var/log* ... Otehrwise I can not help.
> 
> Also: It seems as if the test env is on the cciss machine, and it is
> installed. Could you please elaborate and explain a bit more why this is, if
> you say that it fails to instzall on a cciss machine?

Hi fabiand,

yes, the env is on cciss machine, and rhevh is not installed, for you can ssh access conveniently, so I configured network connection and TUI menu via run"setup" command on shell mode , therefore it looked like installed but actually not.

Thanks!


Hi ycui,

Thank you for the clarification and log info.

Thanks!

Comment 25 cshao 2014-12-23 03:29:46 UTC
Created attachment 972253 [details]
var.log.tar.gz

Upload /var/log/*.* for #c23.

Comment 27 cshao 2014-12-24 10:42:32 UTC
Created attachment 972733 [details]
ccisslog.tar.gz

Comment 28 cshao 2014-12-24 10:44:52 UTC
(In reply to shaochen from comment #27)
> Created attachment 972733 [details]
> ccisslog.tar.gz

This log is for #c26.

Comment 31 Fabian Deutsch 2014-12-28 15:32:56 UTC
Please note that this bug covers several problems, mainly it mixes up a failure to install on cciss during auto-install (see comment 0 / description) and during tui install (see comment 26), with different errors. Additionally it seems to include logs from a hardware related installation failure (see comment 6).

Comment 32 Fabian Deutsch 2015-01-05 09:47:04 UTC
Removing one patch. because it does not seem to be absolutely necessary.

Comment 33 cshao 2015-01-06 07:20:45 UTC
Test version:
rhev-hypervisor6-6.6-20150105.0
ovirt-node-3.1.0-0.39.20150105gitb784105.el6.noarch

Test steps:
1. TUI Install RHEV-H on cciss machine.

Test result:
Install the hypervisor on cciss machine can succeed.

So I will verify this bug after status change to ON_QA

Comment 34 cshao 2015-01-28 10:30:34 UTC
Test version:
rhev-hypervisor6-6.6-20150123.2
ovirt-node-3.2.1-6.el6.noarch

Test steps:
1. TUI Install RHEV-H on cciss machine.

Test result:
Install the hypervisor on cciss machine can succeed.

So the bug has been fixed, change bug status to VERIFIED.

Comment 36 errata-xmlrpc 2015-02-11 21:06:56 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2015-0160.html


Note You need to log in before you can comment on or make changes to this bug.