Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1171824 - VM stuck in "Waiting for launch" in vt13.1 on HE with CPU SLA policy configured on 10%.
Summary: VM stuck in "Waiting for launch" in vt13.1 on HE with CPU SLA policy configur...
Status: CLOSED DUPLICATE of bug 1171491
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine
Version: 3.5.0
Hardware: x86_64
OS: Linux
Target Milestone: ---
: 3.5.0
Assignee: nobody nobody
QA Contact:
Whiteboard: sla
Depends On:
Blocks: rhev35rcblocker rhev35gablocker
TreeView+ depends on / blocked
Reported: 2014-12-08 16:55 UTC by Nikolai Sednev
Modified: 2016-02-10 20:16 UTC (History)
10 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Last Closed: 2014-12-15 13:59:11 UTC
oVirt Team: SLA
Target Upstream Version:

Attachments (Terms of Use)
logs (deleted)
2014-12-08 16:55 UTC, Nikolai Sednev
no flags Details

Description Nikolai Sednev 2014-12-08 16:55:50 UTC
Created attachment 965918 [details]

Description of problem:
VM stuck in "Waiting for launch" in vt13.1 on HE with CPU SLA policy configured on 10%.

I'm simply trying to start one guest VM and it's being stuck in "Waiting for launch" in WEBUI, while shown on host as running.

# vdsClient -s 0 list table
6ffc24c4-40bd-46e9-a655-34e94d76cd1b   7089  RHEL6_5VM1           Up         

From engine I see this:
2014-11-13 18:48:33,227 INFO  [org.ovirt.engine.core.vdsbroker.VdsUpdateRunTimeInfo] (DefaultQuartzScheduler_Worker-7) [2246090c] VM RHEL6_5VM1 (6ffc24c4-4
0bd-46e9-a655-34e94d76cd1b) is running in db and not running in VDS hosted_engine_1

VDSM and libvirt services are running on both hosts OK.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1.On HE environment remove JSon RPC from both hosts, you may also leave it, won't work either.
2.Create CPU profile of 10% at DC, and implement it on created VM with RHEL6.5.
3.Try starting VM.

Actual results:
VM being stuck in "Waiting for launch" in WEBUI, while running on host.

Expected results:
VM should run and be shown properly in both WEBUI and host.

Additional info:
logs attached.

Comment 1 Nikolai Sednev 2014-12-09 08:12:18 UTC
engine=# select vds_name,pending_vmem_size,pending_vcpus_count from vds;
vds_name     | pending_vmem_size | pending_vcpus_count 
hosted_engine_2 |              4096 |                   4
hosted_engine_1 |              7168 |                   7
(2 rows)

Looks like some resources not freed?
I tried also rebooting both hosts with HE over them, not helped.

I also saw some errors in libvirt and vdsm.

Comment 2 Doron Fediuck 2014-12-09 08:16:47 UTC
Looking at the logs you hit Bug 1171491 and your engine is not refreshing.

Re-open if you're able to reproduce without Bug 1171491 effects on a clean

Comment 3 Nikolai Sednev 2014-12-09 08:20:20 UTC
Please review these bugs, they might have the same root cause:

Comment 4 Nikolai Sednev 2014-12-09 13:16:45 UTC
Issue caused while ballooning functionality is enabled on host cluster, 1157211
1169854,1163142 are not related. In case ballooning is enabled, VMs won't start and will stuck in "waiting for launch".
To work around the issue, ballooning have to be disabled.

Issue firstly appeared after upgrading to vt13.1, before that everything worked just fine.

Comment 5 Doron Fediuck 2014-12-09 15:41:44 UTC
this is not bug.
Please add any other comments in Bug 1171491 which is prevents your engine
from refreshing the vm status.

Comment 6 Gil Klein 2014-12-10 10:49:32 UTC
Droron, while this BZ was marked as an RC blocker, I suggest we keep it open for verification purpose, till we get the fix for #1171491.

If it won't be reproducible we will close it as a duplicate.

Comment 7 Nikolai Sednev 2014-12-14 18:24:27 UTC
Works for me with these components, while ballooning is enabled:

Please close as duplicate to 1171491.

Comment 8 Doron Fediuck 2014-12-15 13:59:11 UTC

*** This bug has been marked as a duplicate of bug 1171491 ***

Note You need to log in before you can comment on or make changes to this bug.