Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1168215 - RHEL6.5->6.6 upgrade and RHEVM3.4(av13.3)->3.5(vt11) failed because of the dependency issue
Summary: RHEL6.5->6.6 upgrade and RHEVM3.4(av13.3)->3.5(vt11) failed because of the de...
Keywords:
Status: CLOSED DUPLICATE of bug 1164753
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: redhat-support-plugin-rhev
Version: 3.4.4
Hardware: x86_64
OS: Linux
unspecified
urgent
Target Milestone: ---
: 3.5.0
Assignee: Spenser Shumaker
QA Contact: Spenser Shumaker
URL:
Whiteboard: subeng
Depends On:
Blocks: rhev35rcblocker rhev35gablocker
TreeView+ depends on / blocked
 
Reported: 2014-11-26 12:28 UTC by Nikolai Sednev
Modified: 2014-11-30 07:13 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-11-27 14:26:41 UTC
oVirt Team: ---
Target Upstream Version:


Attachments (Terms of Use)

Description Nikolai Sednev 2014-11-26 12:28:54 UTC
Description of problem:
RHEL6.5->6.6 upgrade and RHEVM3.4(av13.3)->3.5(vt11) failed because of the dependency issue
---> Package sssd-krb5-common.x86_64 0:1.11.6-30.el6 will be installed                                                                                     
extra/filelists_db                                                                                                                  |  99 kB     00:00     
jboss/filelists_db                                                                                                                  |  74 kB     00:00     
qa-latest/filelists_db                                                                                                              | 132 kB     00:00     
rhel/filelists_db                                                                                                                   | 3.2 MB     00:00     
rhel_channel/filelists_db                                                                                                           |  21 kB     00:00     
rhel_optional/filelists_db                                                                                                          | 2.0 MB     00:00     
rhel_zstream/filelists_db                                                                                                           | 7.7 MB     00:03     
rhev_vhannel/filelists_db                                                                                                           |  15 kB     00:00     
--> Finished Dependency Resolution                                                                                                                         
Error: Package: redhat-support-plugin-rhev-3.5.0-1.el6ev.noarch (qa-latest)                                                                                
           Requires: rhevm >= 3.5.0                                                                                                                        
           Installed: rhevm-3.4.4-2.2.el6ev.noarch (@qa-latest)                                                                                            
               rhevm = 3.4.4-2.2.el6ev                                                                                                                     
 You could try using --skip-broken to work around the problem                                                                                              
 You could try running: rpm -Va --nofiles --nodigest                                                                                                       
[root@ovirt-gofen-2 ~]# vim /etc/yum.repos.d/qa-latest.repo 

Version-Release number of selected component (if applicable):


How reproducible:
100%

Steps to Reproduce:
1.Take RHEL6.5 with RHEVM3.4(av13.3) and try to upgrade it at once to both RHEL6.6&RHEVM3.5(vt11) by running "yum update all -y"
2.
3.

Actual results:
Upgrade failed because of the redhat-support-plugin-rhev-3.5.0-1.el6ev.noarch package dependency.


Expected results:
Customer have to succeed performing the all in one upgrade of both RHEL6.5-6.6 and RHEVM3.4->3.5.

Additional info:
Work around used to solve the issue by upgrading rhevm-setup to vt12, as vt11 failes on scrypt, then upgrading the engine by rhevm-setup to 3.5 and only all of these upgrading the rest of the RHEL6.5->6.6 by running "yum update all -y".

Comment 1 Keith Robertson 2014-11-27 14:21:34 UTC
The plug-in is doing the right thing.  It, redhat-support-plugin-rhev-3.5, is saying that it needs RHEV-M 3.5.  Do you have a 3.5 version of the RHEV-M in your yum repo?  If not the upgrade will not work.

Comment 2 Keith Robertson 2014-11-27 14:26:41 UTC

*** This bug has been marked as a duplicate of bug 1164753 ***


Note You need to log in before you can comment on or make changes to this bug.