Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1167860 - agent crashes on wrong metadata
Summary: agent crashes on wrong metadata
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-hosted-engine-ha
Version: 3.5.0
Hardware: Unspecified
OS: Unspecified
unspecified
urgent
Target Milestone: ---
: 3.5.0
Assignee: Doron Fediuck
QA Contact: Artyom
URL:
Whiteboard: sla
Depends On: 1158925 1169308
Blocks: rhev35rcblocker rhev35gablocker
TreeView+ depends on / blocked
 
Reported: 2014-11-25 14:25 UTC by Jiri Moskovcak
Modified: 2016-02-10 20:14 UTC (History)
11 users (show)

Fixed In Version: ovirt-hosted-engine-ha-1.2.4-4.el6ev
Doc Type: Bug Fix
Doc Text:
Clone Of: 1158925
Environment:
Last Closed: 2015-02-11 21:09:15 UTC
oVirt Team: SLA
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:0194 normal SHIPPED_LIVE ovirt-hosted-engine-ha bug fix and enhancement update 2015-02-12 01:35:33 UTC
oVirt gerrit 35517 ovirt-hosted-engine-ha-1.2 MERGED agent: handle malformed metadata better Never

Description Jiri Moskovcak 2014-11-25 14:25:11 UTC
+++ This bug was initially created as a clone of Bug #1158925 +++

Description of problem:
Agent crashes when there is 'null' as the engine-state in the metadata. this was observed while updating from 3.4 to 3.5

Version-Release number of selected component (if applicable):
ovirt-hosted-engine-ha-1.2.4-1.fc19.noarch

How reproducible:
100%

Steps to Reproduce:
1. have metadata where the engine-status field is null
2. start broker and agent
3.

Actual results:
agent crashes with: AttributeError: 'NoneType' object has no attribute 'iteritems'

Expected results:
Agent ignores malformed metadata

Additional info:

--- Additional comment from Sven Kieske on 2014-11-11 03:24:58 EST ---

(In reply to Jiri Moskovcak from comment #0)
> Description of problem:
> Agent crashes when there is 'null' as the engine-state in the metadata. this
> was observed while updating from 3.4 to 3.5

imho therefore it should block 3.5.1 release, would you mind backporting it to 3.5.1?

Comment 2 Artyom 2014-12-23 14:34:28 UTC
Hi Jiri, what the best way to verify this bug?

Comment 3 Jiri Moskovcak 2015-01-02 13:40:39 UTC
1. stop all the agents
2. change the 'engine-status' field in metadata to null
3. start the agent

- the old version will not start, the new version should handle it and update the metadata to valid value

Comment 4 Artyom 2015-01-05 08:31:45 UTC
Verified on ovirt-hosted-engine-ha-1.2.4-5.el6ev.noarch, with Jiri steps

Comment 8 errata-xmlrpc 2015-02-11 21:09:15 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-0194.html


Note You need to log in before you can comment on or make changes to this bug.