Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1167769 - Failed to execute stage 'Setup validation': Failed to clear zombie tasks.
Summary: Failed to execute stage 'Setup validation': Failed to clear zombie tasks.
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-setup
Version: 3.5.0
Hardware: Unspecified
OS: Unspecified
urgent
urgent
Target Milestone: ---
: 3.5.0
Assignee: Yair Zaslavsky
QA Contact: Petr Matyáš
URL:
Whiteboard: infra
Depends On:
Blocks: rhev35rcblocker rhev35gablocker 1166122 1166123
TreeView+ depends on / blocked
 
Reported: 2014-11-25 11:37 UTC by Petr Matyáš
Modified: 2016-02-10 19:36 UTC (History)
15 users (show)

Fixed In Version: vt12
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-02-17 17:07:34 UTC
oVirt Team: Infra
Target Upstream Version:


Attachments (Terms of Use)
Engine-setup log before reboot (deleted)
2014-11-25 11:37 UTC, Petr Matyáš
no flags Details
Engine-setup log after reboot (deleted)
2014-11-25 11:38 UTC, Petr Matyáš
no flags Details


Links
System ID Priority Status Summary Last Updated
oVirt gerrit 35512 ovirt-engine-3.5 MERGED Revert "setup: Changing task cleaner utility to also handle removal of commands" Never

Description Petr Matyáš 2014-11-25 11:37:52 UTC
Created attachment 961165 [details]
Engine-setup log before reboot

Description of problem:
Engine-setup fails with "[ ERROR ] Failed to execute stage 'Setup validation': Failed to clear zombie tasks. Please access support in attempt to resolve the problem" after upgrade from 3.4.

Version-Release number of selected component (if applicable):
3.5

How reproducible:
always on my setup

Steps to Reproduce:
1. install rhevm 3.4 (engine+dwh+reports) and setup 
2. update to 3.5
3. engine-setup

Actual results:
fails in setup validation

Expected results:
doesn't fail

Additional info:

Comment 1 Petr Matyáš 2014-11-25 11:38:25 UTC
Created attachment 961166 [details]
Engine-setup log after reboot

Comment 2 Sandro Bonazzola 2014-11-25 11:53:27 UTC
Can you detail which version of 3.5 are you trying to use?
From logs I see:
rhevm-setup-3.5.0-0.21.el6ev.noarch
but I see also dwh version: rhevm-dwh-3.5.1_master (3.5.1_master) which should have been something like 3.5.0 since rhevm-dwh-3.5.0-7.el6ev.noarch is pulled in.

Comment 3 Petr Matyáš 2014-11-25 11:56:20 UTC
it's vt11, 3.4 was clean install

Comment 4 Sandro Bonazzola 2014-11-25 11:58:45 UTC
2014-11-25 12:13:21 DEBUG otopi.plugins.ovirt_engine_setup.ovirt_engine.upgrade.asynctasks plugin.execute:866 execute-output: ('/usr/share/ovirt-engine/setup/dbutils/taskcleaner.sh', '-l', '/var/log/ovirt-engine/setup/ovirt-engine-setup-20141125121230-xtiroe.log', '-u', 'engine', '-s', 'localhost', '-p', '5432', '-d', 'engine', '-R', '-A', '-J', '-q') stderr:
psql:/usr/share/ovirt-engine/setup/dbutils/taskcleaner_sp.sql:145: ERROR:  type "command_entities" does not exist
FATAL: Cannot execute sql command: --file=/usr/share/ovirt-engine/setup/dbutils/taskcleaner_sp.sql

2014-11-25 12:13:21 DEBUG otopi.context context._executeMethod:152 method exception
Traceback (most recent call last):
  File "/usr/lib/python2.6/site-packages/otopi/context.py", line 142, in _executeMethod
    method['method']()
  File "/usr/share/ovirt-engine/setup/bin/../plugins/ovirt-engine-setup/ovirt-engine/upgrade/asynctasks.py", line 422, in _validateZombies
    self._clearZombieTasks()
  File "/usr/share/ovirt-engine/setup/bin/../plugins/ovirt-engine-setup/ovirt-engine/upgrade/asynctasks.py", line 156, in _clearZombieTasks
    'Failed to clear zombie tasks. Please access support '
RuntimeError: Failed to clear zombie tasks. Please access support in attempt to resolve the problem

Comment 5 Sandro Bonazzola 2014-11-25 12:04:13 UTC
Looks like offending patch may be: http://gerrit.ovirt.org/35220

Comment 6 Shirly Radco 2014-11-25 12:29:13 UTC
The dwh and reports d/s packages are based on the u/s which is already 3.5.1.
I use same branch for the z-stream.

The d/s version is updated according to the d/s build.

The current packages are:
rhevm-dwh-3.5.0-7.el6ev.noarch.rpm
rhevm-dwh-setup-3.5.0-7.el6ev.noarch.rpm
rhevm-reports-3.5.0-10.el6ev.noarch.rpm
rhevm-reports-setup-3.5.0-10.el6ev.noarch.rpm.

Were built for vt10 but added to the repo only on 10.1 because they were built late.

Comment 7 Yedidyah Bar David 2014-11-25 13:12:18 UTC
Following a discussion, Yair will now revert this patch and later fix it to work also on upgrade.

Comment 8 Eyal Edri 2015-02-17 17:07:34 UTC
rhev 3.5.0 was released. closing.


Note You need to log in before you can comment on or make changes to this bug.