Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1167315 - Failed to resume VM [NEEDINFO]
Summary: Failed to resume VM
Keywords:
Status: CLOSED DUPLICATE of bug 1163089
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: rhev-hypervisor
Version: 3.5.0
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ---
: 3.5.0
Assignee: Fabian Deutsch
QA Contact: Nisim Simsolo
URL:
Whiteboard: virt
Depends On:
Blocks: rhev35gablocker
TreeView+ depends on / blocked
 
Reported: 2014-11-24 12:55 UTC by Pavol Brilla
Modified: 2015-11-18 10:39 UTC (History)
11 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-11-24 13:58:15 UTC
oVirt Team: ---
Target Upstream Version:
michal.skrivanek: needinfo?


Attachments (Terms of Use)
log collector (deleted)
2014-11-24 12:55 UTC, Pavol Brilla
no flags Details

Description Pavol Brilla 2014-11-24 12:55:22 UTC
Created attachment 960742 [details]
log collector

Description of problem:
If host is RHEV Hypervisor - 6.6 - 20141119.0.el6ev I got 
"Message: Failed to resume VM aab (Host: jb_borrowed, User: admin)."  when trying to resume VM from suspend state.


Version-Release number of selected component (if applicable):
rhevm-3.5.0-0.21.el6ev
Host: RHEV Hypervisor - 6.6 - 20141119.0.el6ev

How reproducible: 2-3 times from 15 cases
Not always

Steps to Reproduce:
1. Suspend machine ( it doesnt depend on OS of VM )
2. Resume VM
3. Got event message : Failed to resume VM 

Actual results:
Got error message that resuming failed, but VM looks fine 

Expected results:
No error message

Additional info:
2014-11-24 13:08:40,837 ERROR [org.ovirt.engine.core.dal.dbbroker.auditloghandling.AuditLogDirector] (org.ovirt.thread.pool-7-thread-42) [3fd4fd38] Correla
tion ID: 3fd4fd38, Job ID: d59f093c-1269-4286-86e3-f1f84030e7a6, Call Stack: null, Custom Event ID: -1, Message: Failed to resume VM aab (Host: jb_borrowed
, User: admin).

Comment 1 Michal Skrivanek 2014-11-24 13:50:45 UTC
Logs indicate pause/unpause, not suspend. Please clarify

Comment 2 Michal Skrivanek 2014-11-24 13:58:15 UTC

*** This bug has been marked as a duplicate of bug 1163089 ***

Comment 3 Omer Frenkel 2014-11-24 14:00:19 UTC
(In reply to Michal Skrivanek from comment #1)
> Logs indicate pause/unpause, not suspend. Please clarify

in the log i see the vm was paused, not suspended, and the failure looks like json rpc related issue:

2014-11-24 13:08:40,743 ERROR [org.ovirt.engine.core.vdsbroker.vdsbroker.ResumeBrokerVDSCommand] (org.ovirt.thread.pool-7-thread-42) [3fd4fd38] Command ResumeBrokerVDSCommand(HostName = jb_borrowed, HostId = 622092f3-2b25-4e52-b836-5620018ab2d6, vmId=87587ef2-ddb3-4a35-b910-14bb698bb6fb) execution failed. Exception: ClassCastException: java.lang.Boolean cannot be cast to java.util.Map
2014-11-24 13:08:40,743 INFO  [org.ovirt.engine.core.vdsbroker.vdsbroker.ResumeBrokerVDSCommand] (org.ovirt.thread.pool-7-thread-42) [3fd4fd38] FINISH, ResumeBrokerVDSCommand, log id: 5453c1f7
2014-11-24 13:08:40,744 ERROR [org.ovirt.engine.core.vdsbroker.ResumeVDSCommand] (org.ovirt.thread.pool-7-thread-42) [3fd4fd38] VDS::pause Failed resume vm 87587ef2-ddb3-4a35-b910-14bb698bb6fb in vds = 622092f3-2b25-4e52-b836-5620018ab2d6 : jb_borrowed, error = java.lang.ClassCastException: java.lang.Boolean cannot be cast to java.util.Map
2014-11-24 13:08:40,744 INFO  [org.ovirt.engine.core.vdsbroker.ResumeVDSCommand] (org.ovirt.thread.pool-7-thread-42) [3fd4fd38] FINISH, ResumeVDSCommand, return: Unknown, log id: 79f6d594
2014-11-24 13:08:40,744 INFO  [org.ovirt.engine.core.bll.RunVmCommand] (org.ovirt.thread.pool-7-thread-42) [3fd4fd38] Lock freed to object EngineLock [exclusiveLocks= key: 87587ef2-ddb3-4a35-b910-14bb698bb6fb value: VM
, sharedLocks= ]
2014-11-24 13:08:40,744 ERROR [org.ovirt.engine.core.bll.RunVmCommand] (org.ovirt.thread.pool-7-thread-42) [3fd4fd38] Command org.ovirt.engine.core.bll.RunVmCommand throw Vdc Bll exception. With error message VdcBLLException: java.lang.ClassCastException: java.lang.Boolean cannot be cast to java.util.Map (Failed with error ENGINE and code 5001)
2014-11-24 13:08:40,776 INFO  [org.ovirt.engine.core.vdsbroker.VdsUpdateRunTimeInfo] (DefaultQuartzScheduler_Worker-96) [290a6eee] VM aab 87587ef2-ddb3-4a35-b910-14bb698bb6fb moved from Paused --> PoweringUp


this was fixed by bug 1163089


Note You need to log in before you can comment on or make changes to this bug.