Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1167257 - [vdsm] [JSON-RPC] FC domain extension fails with VdsmError
Summary: [vdsm] [JSON-RPC] FC domain extension fails with VdsmError
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: vdsm
Version: 3.5.0
Hardware: x86_64
OS: Unspecified
unspecified
urgent
Target Milestone: ---
: 3.5.0
Assignee: Piotr Kliczewski
QA Contact: Elad
URL:
Whiteboard: infra
Depends On:
Blocks: rhev35rcblocker rhev35gablocker
TreeView+ depends on / blocked
 
Reported: 2014-11-24 10:28 UTC by Elad
Modified: 2016-02-10 19:40 UTC (History)
13 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-02-16 13:38:53 UTC
oVirt Team: Infra
Target Upstream Version:


Attachments (Terms of Use)
vdsm and engine logs (deleted)
2014-11-24 10:28 UTC, Elad
no flags Details

Description Elad 2014-11-24 10:28:32 UTC
Created attachment 960649 [details]
vdsm and engine logs

Description of problem:
Fibre channel storage domain extension fails while engine and host are communicating using JSON-RPC. 
Using XML-RPC, the extenstion succeeds.

Version-Release number of selected component (if applicable):
rhev 3.5 vt11 
vdsm-4.16.7.5-1.el7ev.x86_64
vdsm-jsonrpc-4.16.7.5-1.el7ev.noarch
rhevm-3.5.0-0.21.el6ev.noarch


How reproducible:
Always

Steps to Reproduce:
1. Extend a FC domain using an additional LUN
2.
3.

Actual results:
Extension fails with the following exception in vdsm:

Thread-341::ERROR::2014-11-24 12:12:11,241::__init__::491::jsonrpc.JsonRpcServer::(_serveRequest) Internal server error
Traceback (most recent call last):
  File "/usr/lib/python2.7/site-packages/yajsonrpc/__init__.py", line 486, in _serveRequest
    res = method(**params)
  File "/usr/share/vdsm/rpc/Bridge.py", line 283, in _dynamicMethod
    ret = self._getResult(result, retfield)
  File "/usr/share/vdsm/rpc/Bridge.py", line 102, in _getResult
    raise VdsmError(5, "Response is missing '%s' member" % member)
VdsmErro

engine.log:

2014-11-24 12:12:10,633 ERROR [org.ovirt.engine.core.dal.dbbroker.auditloghandling.AuditLogDirector] (ajp-/127.0.0.1:8702-3) [7494b52a] Correlation ID: 7494b52a, Job ID: 6a57d136-5ada-4ac7-b335-99eb4d04a455, Call Stack: null, Custom Event ID: -1, Message: Failed to connect Host green-vdsb to device. (User: admin)
2014-11-24 12:12:10,641 WARN  [org.ovirt.engine.core.bll.storage.ExtendSANStorageDomainCommand] (ajp-/127.0.0.1:8702-3) [7494b52a] CanDoAction of action ExtendSANStorageDomain failed. Reasons:VAR__TYPE__STORAGE__DOMAIN,VAR__ACTION__EXTEND,ERROR_CANNOT_EXTEND_CONNECTION_FAILED,$hostName green-vdsb,$lun

Expected results:
Storage domain extension should succeed while using JSON-RPC

Additional info:
vdsm and engine logs

Comment 2 Piotr Kliczewski 2014-11-24 14:04:16 UTC

*** This bug has been marked as a duplicate of bug 1161115 ***

Comment 3 Elad 2014-11-24 15:48:09 UTC
This is not the same issue.
This bug was opened for storage domain extension

https://bugzilla.redhat.com/show_bug.cgi?id=1161115 described a scenario in which a virtual disk is resized

Comment 4 Piotr Kliczewski 2014-11-24 16:03:10 UTC
I can see in the log that error was thrown during invocation of the same verb:

Calling 'Host.getDevicesVisibility'

This is the same verb which failed in disk resize bug.

Comment 5 Piotr Kliczewski 2014-11-24 16:12:50 UTC
Why do you think it is different bug?

Comment 6 Oved Ourfali 2014-11-25 07:59:15 UTC
Piotr - if the fix was already applied, then let's move it to MODIFIED.
Elad - once it will move to ON_QA, verify this use case.

Comment 7 Elad 2014-12-16 09:31:14 UTC
FC domain extenstion succeeds while using JSON-RPC

Veirified using rhev 3.5 vt13.3
rhevm-3.5.0-0.25.el6ev.noarch


Note You need to log in before you can comment on or make changes to this bug.