Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1167097 - [SetupNetworks] > RHEV-H host- Can't delete network from NIC after attaching via setup networks
Summary: [SetupNetworks] > RHEV-H host- Can't delete network from NIC after attaching ...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-node
Version: 3.5.0
Hardware: x86_64
OS: Linux
urgent
urgent
Target Milestone: ---
: 3.5.0
Assignee: Fabian Deutsch
QA Contact: Virtualization Bugs
URL:
Whiteboard: node
Depends On:
Blocks: rhev35rcblocker rhev35gablocker
TreeView+ depends on / blocked
 
Reported: 2014-11-23 15:25 UTC by Michael Burman
Modified: 2016-02-10 20:06 UTC (History)
18 users (show)

Fixed In Version: rhev-hypervisor6-6.6-20141218.0.iso rhev-hypervisor7-7.0-20141218.0.iso
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-02-11 21:06:23 UTC
oVirt Team: Node
Target Upstream Version:


Attachments (Terms of Use)
rhev-h and engine logs (deleted)
2014-11-23 15:25 UTC, Michael Burman
no flags Details
screenshot (deleted)
2014-11-23 15:26 UTC, Michael Burman
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2015:0160 normal SHIPPED_LIVE ovirt-node bug fix and enhancement update 2015-02-12 01:34:52 UTC

Description Michael Burman 2014-11-23 15:25:29 UTC
Created attachment 960460 [details]
rhev-h and engine logs

Description of problem:
RHEV-H host> [setup networks] > if attaching network to NIC on host via setup networks window, pressing 'ok' and then trying to remove this network from host(unattach from NIC) you get an error: 'Error while executing action Setup Networks: Unexpected exception' Operation canceled..



Version-Release number of selected component (if applicable):
3.5.0-0.20.el6ev

How reproducible:
always

Steps to Reproduce:
1. install rhev-h host in your setup 
2. attach network to NIC on host via [setup networks] and press 'ok'
3. try to unattach network from NIC via [setup networks]

Actual results:
Fail to unattach network with error:'Error while executing action Setup Networks: Unexpected exception' Operation canceled..

Expected results:
should work as expected

Comment 1 Michael Burman 2014-11-23 15:26:33 UTC
Created attachment 960461 [details]
screenshot

Comment 2 Michael Burman 2014-11-23 15:28:28 UTC
-   virsh -r net-list
Name                 State      Autostart     Persistent
--------------------------------------------------
;vdsmdummy;          active     no            no
vdsm-rhevm           active     yes           yes


-   brctl show
bridge name     bridge id               STP enabled     interfaces
;vdsmdummy;             8000.000000000000       no
net10           8000.00145edd0890       no              eth3.165
rhevm           8000.00145edd088e       no              eth2


As you can see network(net10) was removed from virsh list, but not from brctl show.

Comment 3 Dan Kenigsberg 2014-11-24 14:24:12 UTC
On the relevant host we see

kernel: supervdsmServer[16180]: segfault at 40201f48 ip 00007f6f5e2cbe94 sp 00007f6f4f1718a0 error 4 in libaugeas.so.0.16.0[7f6f5e2c5000+4b000]

which might be related.

Comment 4 Dan Kenigsberg 2014-11-24 14:31:08 UTC
Host has

libvirt-0.10.2-46.el6_6.1.x86_64
vdsm-4.16.7.4-1.el6ev.x86_64
augeas-libs-1.0.0-7.el6.x86_64

Comment 5 Dominic Cleal 2014-11-24 16:16:15 UTC
(In reply to Dan Kenigsberg from comment #4)
> Host has
> 
> libvirt-0.10.2-46.el6_6.1.x86_64
> vdsm-4.16.7.4-1.el6ev.x86_64
> augeas-libs-1.0.0-7.el6.x86_64

(In reply to Dan Kenigsberg from comment #3)
> On the relevant host we see
> 
> kernel: supervdsmServer[16180]: segfault at 40201f48 ip 00007f6f5e2cbe94 sp
> 00007f6f4f1718a0 error 4 in libaugeas.so.0.16.0[7f6f5e2c5000+4b000]
> 
> which might be related.

Could you provide a core, or reproducer on el6 please?

Comment 6 Saggi Mizrahi 2014-11-25 11:51:18 UTC
The problem is actually in a ctypes call in the ovirtnode module.
The this bug needs to be modified and a new bug needs to be opened
to reflect that but I don't know exactly what the process is.

This is the stack trace from the effected host:

(The numbered stack frames are the frames that occur after the most recent
python stack call)


#0  api_entry (aug=0x6c1b5820) at augeas.c:398
#1  0x00007fd983be9721 in aug_set (aug=0x6c1b5820, path=0x7fd9782d65f4 "/augeas/save/copy_if_rename_fails", value=0x7fd993594054 "") at augeas.c:909
#2  0x00007fd98515bdac in ffi_call_unix64 () at src/x86/unix64.S:75
#3  0x00007fd98515bb34 in ffi_call (cif=0x7fd9819bf9c0, fn=0x7fd983be9700 <aug_set>, rvalue=<value optimized out>, avalue=<value optimized out>) at src/x86/ffi64.c:430
#4  0x00007fd98536f074 in _call_function_pointer (pProc=0x7fd983be9700 <aug_set>, argtuple=0x7fd9819bf8a0, flags=4353, argtypes=<value optimized out>, restype=0x1cbe6f0, checker=0x0)
    at /usr/src/debug/Python-2.6.6/Modules/_ctypes/callproc.c:816
#5  _CallProc (pProc=0x7fd983be9700 <aug_set>, argtuple=0x7fd9819bf8a0, flags=4353, argtypes=<value optimized out>, restype=0x1cbe6f0, checker=0x0) at /usr/src/debug/Python-2.6.6/Modules/_ctypes/callproc.c:1163
#6  0x00007fd9853683a2 in CFuncPtr_call (self=<value optimized out>, inargs=<value optimized out>, kwds=0x0) at /usr/src/debug/Python-2.6.6/Modules/_ctypes/_ctypes.c:3860
#7  0x00007fd993027c63 in PyObject_Call (func=0x7fd96c04e940, arg=<value optimized out>, kw=<value optimized out>) at Objects/abstract.c:2492

/usr/lib/python2.6/site-packages/augeas.py (129): set
/usr/lib/python2.6/site-packages/ovirtnode/ovirtfunctions.py (20): <module>
/usr/lib/python2.6/site-packages/ovirtnode/ovirtfunctions.py (20): <module>
/usr/lib/python2.6/site-packages/ovirtnode/ovirtfunctions.py (20): <module>
/usr/lib/python2.6/site-packages/ovirt/node/utils/fs/__init__.py (644): delete
/usr/lib/python2.6/site-packages/ovirt/node/utils/fs/__init__.py (644): delete
/usr/share/vdsm/network/configurators/ifcfg.py (274): _removeFile
/usr/share/vdsm/network/configurators/ifcfg.py (274): _removeFile
/usr/share/vdsm/network/configurators/ifcfg.py (228): _removeSourceRouteFile
/usr/share/vdsm/network/configurators/ifcfg.py (228): _removeSourceRouteFile
/usr/share/vdsm/network/configurators/ifcfg.py (246): removeSourceRoute
/usr/share/vdsm/network/configurators/ifcfg.py (246): removeSourceRoute
/usr/share/vdsm/network/sourceroute.py (90): remove
/usr/share/vdsm/network/configurators/__init__.py (131): _removeSourceRoute
/usr/share/vdsm/network/configurators/ifcfg.py (159): removeBridge
/usr/share/vdsm/network/configurators/ifcfg.py (159): removeBridge
/usr/share/vdsm/network/models.py (171): remove
/usr/share/vdsm/network/api.py (405): delNetwork
/usr/share/vdsm/network/api.py (405): delNetwork
/usr/share/vdsm/network/api.py (206): wrapped
/usr/share/vdsm/network/api.py (206): wrapped
/usr/share/vdsm/network/api.py (569): setupNetworks
/usr/share/vdsm/network/api.py (569): setupNetworks
/usr/share/vdsm/supervdsmServer (222): setupNetworks
/usr/share/vdsm/supervdsmServer (222): setupNetworks
/usr/share/vdsm/supervdsmServer (99): wrapper
/usr/share/vdsm/supervdsmServer (99): wrapper
/usr/lib64/python2.6/multiprocessing/managers.py (199): serve_client
/usr/lib64/python2.6/multiprocessing/managers.py (391): accept_connection
/usr/lib64/python2.6/multiprocessing/managers.py (391): accept_connection
/usr/lib64/python2.6/multiprocessing/managers.py (165): handle_request
/usr/lib64/python2.6/multiprocessing/managers.py (165): handle_request
/usr/lib64/python2.6/threading.py (481): run
/usr/lib64/python2.6/threading.py (513): __bootstrap_inner
/usr/lib64/python2.6/threading.py (490): __bootstrap
/usr/lib64/python2.6/threading.py (490): __bootstrap

Comment 7 Michael Burman 2014-11-25 14:22:32 UTC
Can't reproduce on standard rhel 6.6 server

Comment 8 Michael Burman 2014-11-26 07:24:55 UTC
Followed Fabian steps as he asked:

(This will basically replace the current augeas.py with the most recent one) 

1. Login to RHEV-H
2. Drop to shell by pressing F2 in the setup
3. mount -o remount,rw /
4. cd /usr/lib/python-2.6/site-packages/
5. rm augeas.pyc
6. curl -O https://raw.githubusercontent.com/hercules-team/python-augeas/master/augeas.py
7. mount -o remount,ro /
8. Restart supervdsmd / vdsmd (!!!) (other daemons you know need python-augeas)

9. Do your testing

After this steps i managed to remove network from NIC.

Comment 9 haiyang,dong 2014-11-26 12:08:25 UTC
I could reproduce it in the follow version:
rhevh-6.6-20141119.0.el6ev.iso
ovirt-node-3.1.0-0.27.20141119git24e087e.el6.noarch
Red Hat Enterprise Virtualization Manager Version: 3.5.0-0.21.el6ev

Comment 15 haiyang,dong 2015-01-04 10:46:20 UTC
Test version:
rhev-hypervisor6-6.6-20141218.0.iso(ovirt-node-3.1.0-0.37.20141218gitcf277e1.el6.noarch)
rhev-hypervisor7-7.0-20141218.0.iso(ovirt-node-3.1.0-0.37.20141218gitcf277e1.el7.noarch)

Test steps:
1. install rhev-h host in your setup 
2. attach network to NIC on host via [setup networks] and press 'ok'
3. try to unattach network from NIC via [setup networks]

Test result:
unattach network from NIC success after attaching via setup networks,no exception error was thrown.

so this bug has been fixed, change it into "verified".

Comment 17 errata-xmlrpc 2015-02-11 21:06:23 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2015-0160.html


Note You need to log in before you can comment on or make changes to this bug.