Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1163386 - Mom reporting KeyError: 'vcpuCount' on VM startup
Summary: Mom reporting KeyError: 'vcpuCount' on VM startup
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: mom
Version: 3.5.0
Hardware: All
OS: All
medium
urgent
Target Milestone: ---
: 3.5.0
Assignee: Martin Sivák
QA Contact: Lukas Svaty
URL:
Whiteboard: sla
Depends On:
Blocks: rhev35rcblocker rhev35gablocker
TreeView+ depends on / blocked
 
Reported: 2014-11-12 15:32 UTC by Lukas Svaty
Modified: 2016-02-10 20:17 UTC (History)
8 users (show)

Fixed In Version: mom-0.4.1-2.el6ev
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-02-11 20:27:50 UTC
oVirt Team: SLA
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2015:0186 normal SHIPPED_LIVE mom bug fix and enhancement update 2015-02-12 01:18:26 UTC

Description Lukas Svaty 2014-11-12 15:32:22 UTC
Description of problem:
During VM start:
2014-11-12 04:07:37,430 - mom.Monitor - INFO - GuestMonitor-balloon-1 starting
2014-11-12 04:07:37,431 - mom.Collectors.GuestMemory - WARNING - getVmMemoryStats() error: The ovirt-guest-agent is not active
2014-11-12 04:07:37,432 - mom.Monitor - ERROR - GuestMonitor-balloon-1 crashed
Traceback (most recent call last):
  File "/usr/lib/python2.7/site-packages/mom/GuestMonitor.py", line 56, in run
    self.collect()
  File "/usr/lib/python2.7/site-packages/mom/Monitor.py", line 91, in collect
    collected = c.collect()
  File "/usr/lib/python2.7/site-packages/mom/Collectors/GuestCpuTune.py", line 44, in collect
    stat = self.hypervisor_iface.getVmCpuTuneInfo(self.uuid)
  File "/usr/lib/python2.7/site-packages/mom/HypervisorInterfaces/vdsmInterface.py", line 184, in getVmCpuTuneInfo
    vcpuCount = response['statsList'][0]['vcpuCount']
KeyError: 'vcpuCount'

Version-Release number of selected component (if applicable):
vt9

How reproducible:
100%

Steps to Reproduce:
1. Run VM with GA installed
2. See mom logs during vm start

Actual results:
Log spammed by mentioned keyerror.

Expected results:
Mom should wait while the guest-agent is loaded on VM and that try to get stats from it.

Comment 1 Lukas Svaty 2014-11-12 15:37:41 UTC
also on shutdown this appers from time to time in the events:

2014-11-12 04:27:51,325 - mom.vdsmInterface - ERROR - Traceback (most recent call last):
  File "/usr/lib/python2.7/site-packages/mom/HypervisorInterfaces/vdsmInterface.py", line 210, in setVmCpuTune
    self._check_status(response)
  File "/usr/lib/python2.7/site-packages/mom/HypervisorInterfaces/vdsmInterface.py", line 46, in _check_status
    raise vdsmException(response, self.logger)
vdsmException

Comment 2 Martin Sivák 2014-11-12 15:40:05 UTC
We already have a fix for the first issue. Only a downstream rebuild is needed.

Comment 5 Lukas Svaty 2014-12-04 08:16:23 UTC
verified in mom-0.4.1-2.el6ev

Comment 7 errata-xmlrpc 2015-02-11 20:27:50 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2015-0186.html


Note You need to log in before you can comment on or make changes to this bug.