Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1162774 - CPU SLA policy doesn't updates via Json RPC the VDSM.
Summary: CPU SLA policy doesn't updates via Json RPC the VDSM.
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: vdsm
Version: 3.5.0
Hardware: x86_64
OS: Linux
unspecified
urgent
Target Milestone: ---
: 3.5.0
Assignee: Roy Golan
QA Contact: Nikolai Sednev
URL:
Whiteboard: sla
Depends On: 1143992
Blocks: rhev35rcblocker rhev35gablocker
TreeView+ depends on / blocked
 
Reported: 2014-11-11 16:42 UTC by Nikolai Sednev
Modified: 2016-02-10 20:17 UTC (History)
13 users (show)

Fixed In Version: v4.16.8.1
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-02-16 13:36:47 UTC
oVirt Team: SLA
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Bugzilla 1120246 None None None Never
oVirt gerrit 30074 ovirt-3.5 MERGED Add IO tunables support to updateVmPolicy Never
oVirt gerrit 35236 master ABANDONED API: fix broken updateVmPolicy for jsonrpc Never

Internal Links: 1120246

Description Nikolai Sednev 2014-11-11 16:42:25 UTC
Description of problem:
CPU SLA policy doesn't updates via Json RPC the MOM.

Version-Release number of selected component (if applicable):


How reproducible:
100%

Steps to Reproduce:
1.Create some CPU SLA policy.
2.Try to apply the policy using Json RPC (used by default) on VM.
3.

Actual results:
Policy doesn't applied on VM.

Expected results:
Policy should be applied.

Additional info:
Please forward this bug to Roy Golan, we spoke before on this topic and he's aware of this.

Comment 1 Roy Golan 2014-11-18 15:19:23 UTC
see patch http://gerrit.ovirt.org/#/c/30074/8/vdsm/rpc/vdsmapi-schema.json,cm which will fix this bug.

Comment 2 Nikolai Sednev 2014-12-16 11:08:04 UTC
Depends on 1143992.

Comment 3 Nikolai Sednev 2014-12-24 15:09:21 UTC
works for me on these components:
vdsm-4.16.8.1-4.el7ev.x86_64
qemu-kvm-rhev-1.5.3-60.el7_0.11.x86_64
mom-0.4.1-4.el7ev.noarch
libvirt-client-1.2.8-10.el7.x86_64
sanlock-3.2.2-2.el7.x86_64
rhevm-3.5.0-0.26.el6ev.noarch


Note You need to log in before you can comment on or make changes to this bug.