Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1160795 - [SnapshotOverview] RAM & conf snapshots are not deleted when deleting the last snapshot on the volume chain
Summary: [SnapshotOverview] RAM & conf snapshots are not deleted when deleting the las...
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine
Version: 3.5.0
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: 3.5.0
Assignee: Allon Mureinik
QA Contact:
URL:
Whiteboard: storage
Depends On:
Blocks: 1034885
TreeView+ depends on / blocked
 
Reported: 2014-11-05 16:16 UTC by Ori Gofen
Modified: 2016-05-26 01:48 UTC (History)
12 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-11-09 09:02:45 UTC
oVirt Team: Storage
Target Upstream Version:


Attachments (Terms of Use)

Description Ori Gofen 2014-11-05 16:16:00 UTC
Description of problem:
see bz#1145188 for more description.

When executing a live snapshot, vdsm creates a RAM snapshot of our VM along with a configuration image, those images should be wiped out when removing the last (data) snapshot volume that was associated with that snapshot (from snapshot overview).

Version-Release number of selected component (if applicable):
vt8

How reproducible:
100%

Steps to Reproduce:
1.have a live snapshot
2.delete the snapshot one by one via snapshot-overview

Actual results:
deleting the last volume that belongs to a live snapshot doesn't prompt RAM & conf snapshots deletion

Expected results:
RAM & conf snapshots are unusable when not having storage, thus, need to be wiped out with the last volume

Additional info:

Comment 1 Daniel Erez 2014-11-09 09:02:45 UTC
VM configuration, memory and disks are all separate components of a snapshot. A snapshot with VM configuration or memory only could still be usable in some use-cases (e.g. taking a snapshot in live-cd mode). 
Hence, I don't think there's a special issue to address here.

@Allon - what do you think?

Comment 2 Allon Mureinik 2014-11-09 09:08:20 UTC
(In reply to Daniel Erez from comment #1)
> VM configuration, memory and disks are all separate components of a
> snapshot. A snapshot with VM configuration or memory only could still be
> usable in some use-cases (e.g. taking a snapshot in live-cd mode). 
> Hence, I don't think there's a special issue to address here.
> 
> @Allon - what do you think?

Indeed, this is not a bug - not only is there merit in keeping this snapshots, you can also /explicitly/ ask to create one.


Note You need to log in before you can comment on or make changes to this bug.